cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose M (JIRA)" <>
Subject [jira] [Commented] (CB-13647) Incomplete plugin restoration
Date Tue, 19 Feb 2019 00:19:00 GMT


Jose M commented on CB-13647:

Hi there!

With new cordova versions unwanted plugins are systematically added to the project while building
android apps and cant find a way to get rid of them. Result is creating apps with unnecessary
user permissions. I just created one app which does not need any permission at all but cordova
forced 10 permissions cos it inherited them from the former app i built that required all
those permissions.

I tried some hooks, removed permissions from manifest.xml, android.json etc. but it did not

Not sure if this issue has to do with this reported problem but i did not find another way
to place this issue. Sorry if I bother, I am new here.

Any solution will be appreciated.



> Incomplete plugin restoration
> -----------------------------
>                 Key: CB-13647
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: cordova-android
>    Affects Versions: 7.0.0
>            Reporter: Michael Goffioul
>            Assignee: Joe Bowser
>            Priority: Major
>              Labels: android-next
> I'm having a problem with plugin restoration since cordova-android 7.0.0, when plugins
use a mix of config-file and edit-config on the same file (e.g. AndroidManifest.xml) and only
edit-config uses the real path to the file. I've tried both cordova-cli 6.5.0 and 7.1.0 with
the same result.
> 1) Create a new corodva project and enter top-level direcotyr
> 2) Create subfolder to contain a local plugin: mkdir -p localplugins/testplugin1
> 3) Create the following files to define the local plugin:
> - plugin.xml (adds an attribute to <application> and a category to <intent-filter>)
> {code}
> <?xml version="1.0" encoding="UTF-8"?>
> <plugin xmlns="" id="com.example.testplugin1"
>     <name>Test Plugin 1</name>
>     <platform name="android">
>         <config-file target="AndroidManifest.xml" parent="/manifest/application/activity/intent-filter">
>             <category android:name="android.intent.category.HOME" />
>         </config-file>
>         <edit-config file="app/src/main/AndroidManifest.xml" target="/manifest/application"
>             <application android:largeHeap="true" />
>         </edit-config>
>     </platform>
> </plugin>
> {code}
> - package.json
> {code}
> {
>         "name": "com.example.testplugin1",
>         "version": "1.0.0"
> }
> {code}
> 4) Add android platform: cordova platform add android@7.0.0 --save
> 5) Add local plugin: cordova plugin add localplugins/testplugin1 --save
> At this point, if you check platforms/android/app/src/main/AndroidManifest.xml, it'll
contain the 2 changes defined in the plugin.
> Now attempt to use platform/plugin restoration with thw following:
> {code}
> cordova platform rm android
> cordova prepare android
> {code}
> If you check again AndroidManifest.xml, it will only contain one of the changes defined
in the plugin (the attribute to <application>). The other change is missing.
> If you use the real path to AndroidManifest.xml for the definition of <config-file>,
then the problem does not occur. BUT, the problem can also occur when changes to AndroidManifest.xml
are coming from multiple plugins, including the standard cordova plugin, most of which do
not use the real path to AndroidManifest.xml yet.
> The problem can affect other files too. For instance I experienced incomplete restoration
of plugins trying to register themselves in res/xml/config.xml. Only one plugin, out of 7,
was using the real path app/src/main/res/xml/config.xml and I ended up with only one plugin
defined in res/xml/config.xml, causing the application to fail to start.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message