ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kannan Thiagarajan <kanna...@gmail.com>
Subject Re: export runnable jar issue
Date Mon, 06 May 2013 23:12:24 GMT

I'm facing a similar issue not sure if it is related to this.

I created an eclipse/maven project which just contains a pipeline that
includes many cTAKES components for which I included the Maven
dependencies. Everything worked out fine until I included the Drug NER. I
got the following error.

An import could not be resolved.  No .xml file with name
"org.apache.ctakes.drugner.types.Typesystem" was found in the class path or
data path. (Descriptor:

I tried to add the ctakes-drug-ner-res and it did not resolve the issue. I
could workaround this by copying the contents of ctakes-drug-ner-resources
project but hate doing so. Maybe this is a maven newbie issue.

Any thoughts?


On Tue, Apr 23, 2013 at 10:35 AM, Tim Miller <
timothy.miller@childrens.harvard.edu> wrote:

> It may actually be a maven issue:
> https://bugs.eclipse.org/bugs/**show_bug.cgi?id=284928<https://bugs.eclipse.org/bugs/show_bug.cgi?id=284928>
> I'm a little swamped right now, but I'd like to try setting up a non-maven
> project with two source folders:
> src/main/java
> src/main/resources
> like ours, and see if this issue persists.
> Tim
> On 04/23/2013 11:21 AM, Masanz, James J. wrote:
>> I'm having the same issue.
>> I tried just creating a jar instead of a runnable jar and get the same.
>> Tim, I don't know if it's 1, 2 or 3.
>> -- James
>>  -----Original Message-----
>>> From: dev-return-1533-Masanz.James=m**ayo.edu@ctakes.apache.org<mayo.edu@ctakes.apache.org>[mailto:
>>> dev-
>>> return-1533-Masanz.James=mayo.**edu@ctakes.apache.org<mayo.edu@ctakes.apache.org>]
>>> On Behalf Of Miller,
>>> Timothy
>>> Sent: Sunday, April 21, 2013 7:23 AM
>>> To: dev@ctakes.apache.org
>>> Subject: export runnable jar issue
>>> I've found it useful to "export runnable jar" to create a single file
>>> that
>>> can be run with 'java -jar' on a server/cluster for a given run
>>> configuration. There is an issue that may be an eclipse bug but also may
>>> be a ctakes issue.
>>> The issue is that files under src/main/java source folders export exactly
>>> as expected, while files under src/main/resources folders export with the
>>> "resources" folder prepended. So you will get the following classpaths in
>>> the jar:
>>> org/apache/ctakes/someproject/**SomeCode.class
>>> resources/org/apache/ctakes/**someproject/some_model.bin
>>> This obviously screws up important classpaths at runtime. I can
>>> workaround
>>> it, but does anyone have a sense of whether this issue is:
>>> 1) Clearly an eclipse issue with nothing we can do except try to notify
>>> someone
>>> 2) An eclipse issue but there is something we're doing wrong (like a
>>> convention for resources we're not following that would fix this)
>>> 3) Clearly a ctakes issue
>>> Tim

Best Regards
Kannan Thiagarajan

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message