ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Masanz, James J." <Masanz.Ja...@mayo.edu>
Subject RE: cTAKES Groovy...
Date Thu, 12 Dec 2013 17:01:21 GMT
The story continues:

The @GrabResolver line from Richard did the trick for jwnl.

But I cleared my .groovy/grapes and  .m2/repository and tried running parser.groovy and get
the following:

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
General error during conversion: Error grabbing Grapes -- [download failed: edu.mit.findstruct#findstructapi;0.0.1!findstructapi.jar]

java.lang.RuntimeException: Error grabbing Grapes -- [download failed: edu.mit.findstruct#findstructapi;0.0.1!findstructapi.jar]

FYI. I will take a look but if anyone has any hints, don't be shy

-----Original Message-----
From: dev-return-2299-Masanz.James=mayo.edu@ctakes.apache.org [mailto:dev-return-2299-Masanz.James=mayo.edu@ctakes.apache.org]
On Behalf Of Finan, Sean
Sent: Friday, December 06, 2013 2:38 PM
To: dev@ctakes.apache.org
Subject: RE: cTAKES Groovy...

Good stuff -  Thanks Richard

-----Original Message-----
From: Masanz, James J. [mailto:Masanz.James@mayo.edu] 
Sent: Friday, December 06, 2013 3:30 PM
To: 'dev@ctakes.apache.org'
Subject: RE: cTAKES Groovy...

Thanks Richard! That did the trick

I'll create a JIRA and update the script including adding a comment that that @GrabResolver
 is only needed for pre-OpenNLP 1.5.3 and should be removed when we upgrade to 1.5.3+. and
I'll update CTAKES-191 "Update Apache OpenNLP dependency to 1.5.3" with a  reminder to update
the script.

Trunk of cTAKES still uses 1.5.2-incubating

-----Original Message-----
From: dev-return-2297-Masanz.James=mayo.edu@ctakes.apache.org [mailto:dev-return-2297-Masanz.James=mayo.edu@ctakes.apache.org]
On Behalf Of Richard Eckart de Castilho
Sent: Friday, December 06, 2013 2:12 PM
To: dev@ctakes.apache.org
Subject: Re: cTAKES Groovy...

On 06.12.2013, at 18:01, "Masanz, James J." <Masanz.James@mayo.edu> wrote:

> I have not solved my issues on my ubuntu server yet where "Error 
> grabbing Grapes -- [unresolved dependency: jwnl#jwnl;1.3.3: not found]"

This has also already been fixed in OpenNLP 1.5.3, so there must be some dependency on OpenNLP

Anyway, you should be able to fix it by adding this to the beginning of your Groovy script,
in front of the Grapes:


-- Richard

View raw message