ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hansart Charlotte <hansart.charlo...@gmail.com>
Subject Re: Upgrading guava ?
Date Thu, 23 Feb 2017 07:48:27 GMT
Hi Sean,

Thank you for your answer.

I now use my little cTakes pipeline with guava 18.0 and I get any errors.
Let's note that my pipeline is for now very "basic" : I just launch a
pipeline based on the AggregatePlaintextUMLSProcessor.xml file, so I'm not
using so much third party dependencies at this point.

Thanks again,

Charlotte

2017-02-21 14:25 GMT+01:00 Finan, Sean <Sean.Finan@childrens.harvard.edu>:

> Hi Charlotte,
>
> I honestly don't know if ctakes will break from a guava update.  I suspect
> that it won't for two main reasons.  First, the only code that I've seen in
> ctakes using guava just uses calls to their collections framework, as far
> as I can remember, just to create collections.  That incredibly simplistic
> (and no longer necessary imo) use shouldn't cause problems.   Second,
> though guava is open source and open source releases can have lots of
> untested upgrade gotchas, Google is incredibly thorough in its own testing
> of guava (last I knew they actually use it).
> So, ctakes should be fine.  Famous last words.
> Of course, third party dependencies may rely upon guava more heavily.  I
> think that UimaFit uses the guava "functional" framework.  Another guava
> feature imo no longer necessary given Java improvements over the years, but
> constantly refactoring working code just to switch libraries isn't
> necessarily the best use of scarcely-available time.  I digress ...
>
> So, really the only way to find out is to test.  It could be that somebody
> out there has done this.  Have you been able to try it?  If you do, please
> let us know what happens.  Updating to be compatible with the latest 3rd
> party libs is a big push for our upcoming release.
>
> Thanks,
> Sean
>
> -----Original Message-----
> From: Hansart Charlotte [mailto:hansart.charlotte@gmail.com]
> Sent: Monday, February 20, 2017 2:25 AM
> To: dev@ctakes.apache.org
> Subject: Upgrading guava ?
>
> Hi,
>
> I would like to use cTakes in the same project as another module using a
> more recent version of the Guava dependency (18.0). Do you know if cTakes
> will work with an upgraded version of Guava, or will it produce errors ? Or
> maybe is there other solutions ?
>
> Thank you very much,
>
> Charlotte
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message