ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Finan, Sean" <Sean.Fi...@childrens.harvard.edu>
Subject Re: Errors in Install and examples [EXTERNAL]
Date Mon, 22 Jan 2018 14:55:28 GMT
Hi Don,

To run the standard ctakes clinical pipeline you don't need the ytex module, so indeed do
not panic.  If you are not getting a proper build because of ytex then my advice (without
analyzing that output) would be to just comment out the dependency in the main ctakes pom.
 If you ever do decide to play with ytex then you can tackle any build problems at that time.

Don't use the MultiThreadedPipeline in ctakes examples.  I am 99% sure that it doesn't work
(I've run it, gotten errors, and then hunted through the code until I found unprotected shared
objects.)  If you do want to try a thread safe pipeline then I recommend that you get the
trunk version of ctakes.  With that you can build using the "runPiperSubmitter" maven profile
to launch a gui.  In the gui select the "TsFastClinicalPipeline" (or something like that)
in ctakes-clinical-pipeline-res.  "Ts" stands for thread-safe and you can find Ts piper files
throughout the ctakes *-res projects.

You can check progress /comments at this jira item (ctakes-485):
https://issues.apache.org/jira/browse/CTAKES-485?jql=project%20%3D%20CTAKES%20ORDER%20BY%20created%20DESC

Sean
________________________________________
From: Don Flinn <flinn@alum.mit.edu>
Sent: Sunday, January 21, 2018 9:41 PM
To: dev@ctakes.apache.org
Subject: Errors in Install and examples [EXTERNAL]

Hi,

I'm new toctakes.  I installed the system as per the cTakes 4.0 Developer
install Guide into eclipse running on Windows 10.  It mostly went well.
However, there were errors in the build for the ctakes-ytexs in the pom.xml
<execution> elements.  It said 'don't panic" so I'm not -:).  However, due
my novice status, I don't know how to fix this.  The error message is
below.  Some ideas would be appreciated

I also ran through the examples and MultiTheadedPipeline.java had an error
shown below:  I would appreciate any insight into these errors.

I still have a lot of work to do to understand all the output and
processes, but I want to first get the install correct.  I've been reading
the ctakes, UMIA and NPL documents and articles.  I would appreciate any
pointers to pertinent references that I should read.

Thanks,
Don

========================================Build error
==============================

An Ant BuildException has occured: The following error occurred while
executing this line: C:\apache-ctakes-4.0.0Dev\ctakes\ctakes-
 ytex\scripts\build-setup.xml:113: Problem: failed to create task or type
if Cause: the class net.sf.antcontrib.logic.IfTask was not found. Action:
 Check that the component has been correctly declared and that the
implementing JAR is in one of: -ANT_HOME\lib -the IDE Ant configuration
 dialogs Do not panic, this is a common problem. It may just be a
typographical error in the build file or the task/type declaration. The
commonest
 cause is a missing JAR. This is not a bug; it is a configuration problem
(org.apache.maven.plugins:maven-antrun-plugin:1.6:run:generate-test-
 config:pre-integration-test) org.apache.maven.plugin.MojoExecutionException:
An Ant BuildException has occured: The following error occurred
 while executing this line: C:\apache-ctakes-4.0.0Dev\
ctakes\ctakes-ytex\scripts\build-setup.xml:113: Problem: failed to create
task or type if Cause:
 the class net.sf.antcontrib.logic.IfTask was not found. Action: Check that
the component has been correctly declared and that the implementing
 JAR is in one of: -ANT_HOME\lib -the IDE Ant configuration dialogs Do not
panic, this is a common problem. It may just be a typographical error
 in the build file or the task/type declaration. The commonest cause is a
missing JAR. This is not a bug; it is a configuration problem at
 org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:283) at
 org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(
DefaultBuildPluginManager.java:134) at
 org.eclipse.m2e.core.internal.embedder.MavenImpl.execute(MavenImpl.java:331)
at
 org.eclipse.m2e.core.internal.embedder.MavenImpl$11.call(MavenImpl.java:1362)
at
 org.eclipse.m2e.core.internal.embedder.MavenImpl$11.call(MavenImpl.java:1)
at
 org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(
MavenExecutionContext.java:177) at
 org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(
MavenExecutionContext.java:112) at
 org.eclipse.m2e.core.internal.embedder.MavenImpl.execute(MavenImpl.java:1360)
at
 org.eclipse.m2e.core.project.configurator.MojoExecutionBuildParticipant.
build(MojoExecutionBuildParticipant.java:52) at
 org.eclipse.m2e.core.internal.builder.MavenBuilderImpl.build(MavenBuilderImpl.java:137)
at
 org.eclipse.m2e.core.internal.builder.MavenBuilder$
1.method(MavenBuilder.java:172) at
 org.eclipse.m2e.core.internal.builder.MavenBuilder$1.method(MavenBuilder.java:1)
at
 org.eclipse.m2e.core.internal.builder.MavenBuilder$BuildMethod$1$1.call(MavenBuilder.java:115)
at
 org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(
MavenExecutionContext.java:177) at
 org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(
MavenExecutionContext.java:112) at
 org.eclipse.m2e.core.internal.builder.MavenBuilder$BuildMethod$1.call(MavenBuilder.java:105)
at
 org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(
MavenExecutionContext.java:177) at
 org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(
MavenExecutionContext.java:151) at
 org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:99)
at
 org.eclipse.m2e.core.internal.builder.MavenBuilder$BuildMethod.execute(MavenBuilder.java:86)
at
 org.eclipse.m2e.core.internal.builder.MavenBuilder.build(MavenBuilder.java:200)
at
 org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:735)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at
 org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:206)
at
 org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:246)
at
 org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:301)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at
 org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:304)
at
 org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:360)
at
 org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:383)
at
 org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:142)
at
 org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:232)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56) Caused by: C:
 \apache-ctakes-4.0.0Dev\ctakes\ctakes-ytex\target\antrun\build-main.xml:5:
The following error occurred while executing this line: C:\apache-
 ctakes-4.0.0Dev\ctakes\ctakes-ytex\scripts\build-setup.xml:113: Problem:
failed to create task or type if Cause: the class
 net.sf.antcontrib.logic.IfTask was not found. Action: Check that the
component has been correctly declared and that the implementing JAR is in
 one of: -ANT_HOME\lib -the IDE Ant configuration dialogs Do not panic,
this is a common problem. It may just be a typographical error in the
 build file or the task/type declaration. The commonest cause is a missing
JAR. This is not a bug; it is a configuration problem at
 org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:497)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:
 444) at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.GeneratedMethodAccessor152.invoke(Unknown
 Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source) at
 org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348) at
 org.apache.tools.ant.Target.execute(Target.java:390) at
org.apache.tools.ant.Target.performTasks(Target.java:411) at
 org.apache.tools.ant.Project.executeSortedTargets(Project.java:1397) at
org.apache.tools.ant.Project.executeTarget(Project.java:1366) at
 org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:270) ...
32 more Caused by: C:\apache-ctakes-4.0.0Dev\ctakes\ctakes-
 ytex\scripts\build-setup.xml:113: Problem: failed to create task or type
if Cause: the class net.sf.antcontrib.logic.IfTask was not found. Action:
 Check that the component has been correctly declared and that the
implementing JAR is in one of: -ANT_HOME\lib -the IDE Ant configuration
 dialogs Do not panic, this is a common problem. It may just be a
typographical error in the build file or the task/type declaration. The
commonest
 cause is a missing JAR. This is not a bug; it is a configuration problem
at
 org.apache.tools.ant.UnknownElement.getNotFoundException(UnknownElement.java:487)
at
 org.apache.tools.ant.UnknownElement.makeObject(UnknownElement.java:419) at
 org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:163)
at org.apache.tools.ant.Task.perform(Task.java:347) at
 org.apache.tools.ant.Target.execute(Target.java:390) at
org.apache.tools.ant.Target.performTasks(Target.java:411) at
 org.apache.tools.ant.Project.executeSortedTargets(Project.java:1397) at
 org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
at
 org.apache.tools.ant.Project.executeTargets(Project.java:1249) at
org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:442) ... 43 more

===================== MultiTheadedPipeline.java
error===================================
** Configuration Error: file:\C:\apache-ctakes-4.0.
0Dev\ctakes\ctakes-lvg-res\target\classes\org\apache\
ctakes\lvg\data\config\lvg.properties (The filename, directory name, or
volume label syntax is incorrect)
** Error: problem of opening/reading config file:
'file:\C:\apache-ctakes-4.0.0Dev\ctakes\ctakes-lvg-res\
target\classes\org\apache\ctakes\lvg\data\config\lvg.properties'. Use -x
option to specify the config file path.
** Configuration Error: file:\C:\apache-ctakes-4.0.
0Dev\ctakes\ctakes-lvg-res\target\classes\org\apache\
ctakes\lvg\data\config\lvg.properties (The filename, directory name, or
volume label syntax is incorrect)
** Error: problem of opening/reading config file:
'file:\C:\apache-ctakes-4.0.0Dev\ctakes\ctakes-lvg-res\
target\classes\org\apache\ctakes\lvg\data\config\lvg.properties'. Use -x
option to specify the config file path.

Mime
View raw message