ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Abramowitsch <pabramowit...@gmail.com>
Subject Re: Trunk Build, Jcasgen reports API incompatibility
Date Mon, 07 May 2018 06:08:36 GMT
Hello.  Here's a bit more information on the problems I was having
compiling the trunk from source.  I've tried with more success outside
Eclipse, but still having issues.

*Outside of Eclipse* If I do the mvn clean install of the whole ctakes,
JCasgen does run normally. and the typesystem jar is generated  All the
projects build and test* with the exception of ctakes-temporal*.  (see
attached compile output).  The errors start with this:

[ERROR]
/Users/peterabramowitsch/hbm-java/apache-ctakes-4/trunk/ctakes-temporal/src/main/java/org/apache/ctakes/temporal/ae/TemporalRelationExtractorAnnotator.java:[102,27]
[unchecked] unchecked generic array creation for varargs parameter of type
RelationFeaturesExtractor<IdentifiedAnnotation,IdentifiedAnnotation>[]

I tried putting in some SuppressWarnings... but got into more trouble.


*Inside of eclipse*, if I do the type-system clean/install on its own,
casgen still fails with this.

Execution default of goal
org.apache.uima:jcasgen-maven-plugin:2.10.2:generate failed: Unable to load
the mojo 'generate' in the plugin
'org.apache.uima:jcasgen-maven-plugin:2.10.2' due to an API
incompatibility:
org.codehaus.plexus.component.repository.exception.ComponentLookupException:
org/apache/uima/tools/jcasgen/maven/JCasGenMojo : Unsupported major.minor
version 51.0

And therefore every project depending on the typesystem fails.


platform
Java jdk1.8.0_25
eclipse Version: Luna Service Release 2 (4.4.2)Build id: 20150219-0600

Mime
View raw message