ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Abramowitsch <pabramowit...@gmail.com>
Subject Jcasgen reports API incompatibility error on cTakes trunk
Date Sun, 06 May 2018 06:20:20 GMT
Hello.   I just checked out the trunk into Eclipse with the Maven &
Subversive plugins.    The build stumbles doing the Jcasgen of every
project that has a typesystem.   There seems to be a version
incompatibility:

Execution default of goal
org.apache.uima:jcasgen-maven-plugin:2.10.2:generate failed: Unable to load
the mojo 'generate' in the plugin
'org.apache.uima:jcasgen-maven-plugin:2.10.2' due to an API
incompatibility:
org.codehaus.plexus.component.repository.exception.ComponentLookupException:
org/apache/uima/tools/jcasgen/maven/JCasGenMojo : Unsupported major.minor
version 51.0

Also If I try to Maven-update the whole project I get

An internal error occurred during: "Updating Maven Project".
java.lang.NullPointerException

It seems to be related to ctakes-temporal as I can update all of the others
individually.


Can anyone shed any light on either of these issues?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message