db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Susan Cline <home4...@pacbell.net>
Subject Re: Derby start up problems on linux.
Date Tue, 06 Dec 2005 22:46:52 GMT
Hi Mike,
  This may not be related, but I have seen problems on Linux when starting the network server
using the word "localhost".  From within Eclipse, bring up the properties for the project
you've added the plug-ins to and set the Apache Derby Network Server Host value to the ip
address of your linux host (instead of localhost.)
  Restart the server and see if this works.
MIKE SCHWEIGER <mcschweiger@rogers.com> wrote:
     I'm using Linux Fedora core 4 and working through the eclipse derby plugin help section.
I start the server from within eclipse and it seems ok. I get

Server is ready to accept connections on port 1527.

When I run netstat, port 1527 is in the LISTEN mode. Also I can see the process active.

using IJ I get the following.
ij> connect
ERROR (no SQLState): java.security.PrivilegedActionException : Error
opening socket to server localhost on port 1527 with message : null

When I look at the derby.log there is no evidence of a connection. When I try to do a shutdown
I get 

Could not connect to Derby Network Server on the host localhost, port 1527.

I have also tried t he ping argument in NetworkServerControl with no success.

I have used telnet to make a connection, and when I submit a message I get a protocol failure
which makes sense.  The failure also shows up in the log file.

I'm open to suggestions.  Thanks. 

View raw message