db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Supal Patel <supal.pa...@in.ibm.com>
Subject Re: Not able to create encrypted database
Date Tue, 11 Jul 2006 07:24:56 GMT
Myrna van Lunteren <m.v.lunteren@...> writes:

> On 7/6/06, Supal Patel <supal.patel@...> wrote:
> [snip details about the problem]
> > This makes sense because you dont 
have 'com.ibm.j9.jce.provider.J9JCEProvider'
> > in your classpath.
> >
> > But in my case I do have j9jceprov.jar in my classpath. And that is why I 
> > getting error as mentioned below :
> >
> > ERROR XBM01: Startup failed due to an exception. See next exception for
> > details.
> > ERROR XBCXG: The encryption provider 'J9JCEProvider' does not exist.
> >
> > So now what I want to understand is what causes this error message  :
> >
> > I am using J9 (JCL:MAX) JRE and Derby 10.1.2 database.
> >
> > Can anyone please help me ?
> >
> > Thanks and Regards,
> >
> > Supal Patel
> >
> >
> >
> Hi Supal,

Hi Myrna,

Sorry for replying late.. Thanks in advance for helping me...
> I have never tried the encryption provider you mentioned, and I lost
> (due to a hard disk crash) my installed j9 files...But I will try to
> help...

> What OS are you working on, and what version of j9 do you have (so I
> can try to get a similar set up)?

I am using WinXP and J9 JCL MAX.

> Also, I am wondering how exactly your jvm is started.
> Specifically, do you use the -Xbootclasspath?
> Have you been able to use the j9jceprov.jar with other products (not derby)?
I have not tried this. I tried to use this jar for the first time with Derby 

> And, based on the commented-out line in JDBC_Test.java I wonder if you
> were able to create an encrypted database with the
> BouncyCastleProvider?
Let me explain this in detail. Currently I have two JREs on my system: 1. IBM 
JRE1.4.2 and J9 JCL Max. 

If I run the same code on IBM 1.4.2 JRE and use BouncyCastle provider then it 
works fine. I can successfully create a encrypted databse. Now if I just 
change the JRE to J9 then the same code gives me exception that : 
ERROR XBCXC: Encryption algorithm 'DES/CBC/NoPadding' does not exist. Please 
check that the chosen provider 'BC' supports this algorithm.

Now on J9 JRE if I use j9jceprov.jar and com.ibm.j9.jce.provider.J9JCEProvider 
then as mentioned in my previous post it gives me exception that : 
ERROR XBCXG: The encryption provider 'J9JCEProvider' does not exist.
Please note that its not a class path issue because the j9jceprov.jar is in 

Thanks and Regards,

> Thx,
> Myrna

View raw message