db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sitsky <s...@nuix.com.au>
Subject Re: SQLSTATE: XSDG0Page Page(7,Container(0, 848)) could not be read from disk.
Date Wed, 11 Oct 2006 04:48:49 GMT
>> At the end of my message, are the contents of the derby.log file, 
>> which seem to indicate that perhaps the seg0/c350.dat file has been 
>> truncated somehow, due to the EOFException being thrown?
> The times I have seen this, the file hasn't actually been truncated. The
> problem has been some issue where the log thinks a page should be there
> but it never got to the file.  For instance assuming 4k pages it looks
 > [...]
> Some causes in the past are:
> o DERBY-700
> o DERBY-1838
> o using durability=test mode
> o running on hardware that doesn't actually sync disk when asked
> o running separate jvm's on 2 machines accessing the same db across a
>   networked file system.

This is running on windows, we never set durability=test, so I highly 
suspect the last point must have occurred at this site.

>> For what its worth, the size of the seg0/c350.dat file is 12288 bytes. 
>> I've included the directory listing of the database files in this 
>> message in case there is any useful information here.
> Do you know the page size of the table?  Default is 4k unless there are
> some blob/clob columns, but size is user setable.

One of the tables does use a clob field, and the default page size 
hasn't been changed.

>> What is interesting, is I get the same error messages if I try and 
>> open the database with release and  I tried opening 
>> it with, and the database can be opened fine (no errors 
>> reported in derby.log).
> Did you boot with the upgrade=true flag or not?

No I didn't.  I just tried connecting to it with update=true, and I get 
the same amount of data available.

>> Any ideas on what can be done here to try and recover more data?  Many 
>> thanks again for your help.
> If the data is not sensitive posting the db to a jira issue may help,
> sounds like db is not that big.

Its not big - but unfortunately, as much as I'd love to post it, I 
can't, as it contains sensitive data...

Many thanks for your help.  I highly suspect the multiple-JVM over a 
networked filesystem scenario must have occurred accidently.


Nuix Pty Ltd
Suite 79, 89 Jones St, Ultimo NSW 2007, Australia    Ph: +61 2 9280 0699
Web: http://www.nuix.com.au/                        Fax: +61 2 9212 6902

This message is intended only for the named recipient. If you are not
the intended recipient you are notified that disclosing, copying,
distributing or taking any action in reliance on the contents of this
message or attachment is strictly prohibited.

View raw message