db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Kartha <karth...@gmail.com>
Subject Re: Wrong ULR in Eclipse Plug-in Lab
Date Thu, 15 Feb 2007 19:21:22 GMT
A. Rick Anderson wrote:
> Is there a bug in the eclipse plug-in for ij?  I've installed the 
> eclipse-plug-in and when attempting to run the labs, it fails with the 
> following message.  I have installed the Derby Nature in the project 
> DerbyLab.
> ij> connect 
> 'jdbc:derby:net://localhost:1527/jayDB;create=true;user=APP;password=APP;'; 
> ERROR 08001: No suitable driver found for 
> jdbc:derby:net://localhost:1527/jayDB;create=true;user=APP;password=APP;
> When I googled this error message, it showed that the URL is different 
> then derby is expecting it to be, but this would imply that there is a 
> bug in the ij.bat script, something that would never pass any form of 
> regression test.
> I've tried setting DERBY_HOME, and that didn't change the behavior.
> When I did the derby getting_started activities from the command-line, 
> they all worked fine.  It's just within Eclipse that I seem to be 
> having this challenge.
> The only JRE or JDK on my machine is 1.6.  But I have Java 1.6, derby 
> 10.2.2 and I downloaded the latest JavaDB from Sun.  But since they 
> all fundamentally share the exact same code, I don't see where this 
> should cause a problem.
Hi Rick,


Looks like the url in the jay_tables.sql file needs a minor fix and change




The other sql files show the correct url. The above url uses the Derby 
client driver to connect
to the server.

Do post to the mail should come across any other issues.


View raw message