db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Waagan <Kristian.Waa...@Sun.COM>
Subject Re: Upgrading Issues
Date Wed, 04 Nov 2009 14:14:17 GMT
Allgeyer, Jessica wrote:
> Recently we have upgraded our Derby DB from  to With the latest version,
 api CALL SYSCS_UTIL.SYSCS_IMPORT_TABLE is throwing the error 'java.lang.NullPointerException'
when a file is empty. After investigation, any version above our previous version of
causes this error. Can you provide us with a solution or adjustments we need to make on our
end? Please let me know if you need more information provided. 
Hello Jessica,

I'm not able to reproduce with neither 10.5 nor the development trunk, 
so more information would be useful.
(Just noticed Rick reporting the same.)

I simply tried importing a file of size zero bytes, and that worked 
(i.e. nothing happened).
Some suggestions:
 - Can you provide the stack trace from the NullPointerException?
  (remove traces you don't want to reveal if necessary)
 - Is the file zero bytes, or is there at least one character/byte 
(visible or non-visible) in there?
 - Can you specify the full import call?
 - What's your platform? Do you already now that the bug occurs at any 

The best thing you can do is to provide a small repro script :)


> Thanks
> Jessica Allgeyer
> (513) 763 - 8523
> ********************************************************************** The content of
this e-mail message and any attachments are confidential and may be legally privileged, intended
solely for the addressee. If you are not the intended recipient, be advised that any use,
dissemination, distribution, or copying of this e-mail is strictly prohibited. If you receive
this message in error, please notify the sender immediately by reply email and destroy the
message and its attachments. **********************************************************************


View raw message