db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tobias Hilka" <thi...@vps.de>
Subject AW: Antwort: Problems executing BasePeer.doUpdate(Criteria, Criteria, Connection)
Date Mon, 08 Jan 2007 07:54:22 GMT
Hi Thomas,

I am sure it works with Integer values. But it would be very nice not having
to think about converting booleanints and booleanchars when calling this
method. If this solution is not possible, I would have to change all
occurrences of this call to use Integer values. But for programmers just
using Torque it is hard, always having to know which mehtod can be called
with which kind of Boolean/Integer value.

Do you plan to change this behaviour?

Best regards,

-----Urspr√ľngliche Nachricht-----
Von: Thomas Fischer [mailto:fischer@seitenbau.net] 
Gesendet: Freitag, 5. Januar 2007 18:26
An: Apache Torque Developers List
Betreff: Antwort: Problems executing BasePeer.doUpdate(Criteria, Criteria,

If I remember correctly, the doUpdate(Criteria, Criteria, Connection) method
expects booleanints and booleancher being already converted to Integer and
Char. Have you tried using a new Integer(1) for true or a new
Integer(0) for false, respectively ?


"Tobias Hilka" <thilka@vps.de> schrieb am 05.01.2007 18:15:47:

> Hello everyone,
> We are having trouble executing the doUpdate(Criteria, Criteria,
> method from BasePeer. The update we want to perform is changing the 
> value
> a field of type BOOLEANINT and we use a Boolean object to express the 
> new state of the object in the update Criteria, we get an error 
> conserning
> value we want to insert in the table.
> We tried it both, for MSSQL Server and Oracle, and each time we got an
> message.
> For MSSQL:
> org.apache.torque.TorqueException:
> Bad conversion: java.lang.NumberFormatException: For input string:
>    at
> org.apache.torque.util.BasePeer.throwTorqueException(BasePeer.java:109)
>    at
> org.apache.torque.util.BasePeer.insertOrUpdateRecord(BasePeer.java:635)
>    at org.apache.torque.util.BasePeer.access$000(BasePeer.java:79)
>    at org.apache.torque.util.BasePeer$4.process(BasePeer.java:1220)
>    at org.apache.torque.util.BasePeer.processTables(BasePeer.java:1736)
>    at org.apache.torque.util.BasePeer.doUpdate(BasePeer.java:1215)
> For Oracle:
> Don't have the exact message any more, but something like: Update to 
> null not possible.
> Debugging this problem I found that there is a doUpdate(Criteria,
> Connection) method for each BasePeer. Therein the method
> correctBooleans(criteria) is called which replaces Boolean.TRUE to
> Integer(1) and Boolean.FALSE to Integer(0). I can not find this call 
> in
> BasePeer.doUpdate(Criteria, Criteria, Connection) method.
> Could it be that this call is missing there or is there any other
> of this problem there?
> Thank you for your help.
> Have a nice weekend.
> Tobias

To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message