db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Eade <se...@backstagetech.com.au>
Subject Re: Torque 3.3.RC2 problem with turbine applications
Date Thu, 29 Mar 2007 15:01:19 GMT
Thomas Vandahl wrote:
> Jeffrey D. Brekke wrote:
>> Are you useing YAAFI inside turbine 2.3.2 instead of Avalon?
> Yes. I use YAAFI as an Avalon container to be precise. There is a 
> TurbineYaafiComponentService in the contrib-directory of YAAFI which 
> can replace the ECM-based AvalonComponentService of Turbine 2.3.2.
> See https://issues.apache.org/jira/browse/TRB-27 for my patches to 
> make this 1:1 compatible.
Thomas, this is really great.  I have been using it all week in my 
development environment and it seems to have worked fine 
(torque-3.3.RC1/RC2 using the maven-jetty-plugin on Java 1.5).

I have just pushed this over to a staging site that runs tomcat 5.0 on 
Java 1.4.2 - initially it worked with torque-3.3.RC1, but eventually it 
starts getting NPEs, either from BasePeer on line 1670:
    ColumnMap[] columnMaps = dbMap.getTable(table).getColumns();
or from SQLBuilder on line 494:
    ColumnMap column = dbMap.getTable(table).getColumn(columnName);

With torque-3.3.RC2 it starts getting the NPEs immediately from BasePeer 
line 1632:
    ColumnMap[] columnMaps = dbMap.getTable(table).getColumns();

Would you have any suggestions as to what my problem might be?



To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message