db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Vandahl ...@apache.org>
Subject Re: Change semantics of Criteria.add() and Criteria.or()
Date Mon, 12 Dec 2011 15:59:21 GMT
Am 12.12.2011 15:07, schrieb Thomas Fox:
> 1) deprecate or remove the existing class and create a new one. Variants:
> 1a) move the new class to a new package

While the danger of an automatic "Organize imports" still exists, it is 
probably the best solution.

> 2) deprecate the existing methods and create new ones. We could
> deprecate/remove the add methods and tell the user to use the and methods.
> But I do not have a good new name for the "or" methods.

Its not really a good solution but what about AND() and OR().

> 3) Because of TORQUE-168, new methods have been added which use a Column
> object as column name. Until now, Strings have been used as column name. We
> could deprecate/remove the methods which use String values. This means that
> people which do NOT use the constants from the Peer classes have more work.

Yeah, but I'd prefer more work over the possibility of wrong code. Anytime.

Bye, Thomas.

To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message