db-torque-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fox <Thomas....@seitenbau.net>
Subject RE: Change semantics of Criteria.add() and Criteria.or()
Date Sun, 15 Jan 2012 15:02:21 GMT
Thanks a lot, Greg, for your suggestions.

Greg Monroe wrote:
> Some take it or leave it suggestions:
> We might still want to refactor to the Factory methodology
> even if there is only one class.  This would make it easier
> for future versions to do Criteria changes without as much
> disruption or for application developers to add in their
> own (DB Type specific?) versions.

I'd rather not add complexity which is not needed. It will mean three
classes (interface, implementation and factory)
instead of one, and I honestly do not see a compelling use case.

> I'd suggest that the Column, ColumnImpl, and ColumnValue
> classes be moved into this new criteria package.  AFAIK,
> they are only used by the Criteria class and putting them
> there will keep down confusion between ColumnMap and
> Column.

Hm, as both Database and Table are in the package where Column is now, I'd
rather leave it there.


To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org

View raw message