directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Schliesing <>
Subject [naming] Meaningless FileNotFoundException
Date Fri, 08 Dec 2006 09:21:04 GMT

I tried to hunt down this bug myself but the link from to the Source 
Repositories gives me a 404.
Furthermore the Issue tracking seems to be down too, so I'm posting it 
to this list.

Maybe someone out there likes to check this one:
Yesterday I spent some time setting up Struts. I copied the config-file 
from one of our other projects and got a weird Stack Trace:
[2006-12-08 10:10:42,129, ERROR] 
org.apache.struts.action.ActionServlet:768: Parsing error processing 
resource path /WEB-INF/struts-config.xml
	at org.apache.xerces.impl.XMLEntityManager.setupCurrentEntity(Unknown 

I triple checked the struts-config.xml and after some time I realised 
that the dtd-line looks somewhat strange:
<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD 
Struts Configuration 1.3//EN" "../dtds/struts-config_1_2.dtd">

Changing this to
<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD 
Struts Configuration 1.3//EN" 
solved the FNFE.

But the meaningless FNFE-message still confused me. So I changed the 
path to the dtd to:

Now I got a proper FNFE-message: 

A meaningfull message like this could have saved me plenty of time.

Maybe someone could look at the code an fix this issue.



View raw message