directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrei Tchijov (JIRA)" <>
Subject [jira] Updated: (DIRSERVER-810) ldap_search_s hangs
Date Wed, 03 Jan 2007 12:53:27 GMT


Andrei Tchijov updated DIRSERVER-810:

    Attachment: DIRSERVER-810.log-1.bin

	Thanks for ultra quick response. Please find attached to this e-mail  
2 files (I am trying to attach these files to JIRA issue, but for  
some reason jira is super slow today ??? ):

		DIRSERVER-810.log-1.bin - binary output from tcpdump,
		DIRSERVER-810.server.log-1.txt - server side log file (it is 1.0  
log. I will e-mail new log as soon as I build new installer from the  

	The last search request is the one which correspond with hanging  
ldap_search_s call. I have tried to adjust filter (to remove trailing  
spaces) -- result still the same. The search request in questions,  
supposed to fail (my interceptor making sure that it fails). The  
problem is that on this particular request, none of interceptors get  
invoked.  Also, the very same search works works just fine if used  
under slightly different scenario (different sequence of bind/search  
requests generated by ldapauth).

Andrei Tchijov
Scalable Biometrics, LLC

> ldap_search_s hangs 
> --------------------
>                 Key: DIRSERVER-810
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: ldap
>    Affects Versions: 1.0
>         Environment: Client: Windows XP
> Server: Mac OS X
>            Reporter: Andrei Tchijov
>         Attachments: DIRSERVER-810.ldapSearchCompare.c, DIRSERVER-810.log-1.bin, DIRSERVER-810.log-1.txt,
DIRSERVER-810.pgina.log-1.txt, DIRSERVER-810.server.log-1.txt
> I am trying to use pGINA ldapauth module against ApacheDS.  It mostly work, but there
is one scenario when ldap_search_s call hangs indefinitely.  I am quite sure that ldap_search_s
gets invoked and I am almost sure that it gets invoked with good parameters.  On server side,
I know that none of interceptors gets invoked for this request.  I have captured packets with
tcpdump and will attach results to this ticket.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message