directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <>
Subject Re: RPM Factory Uploaded to Sandbox
Date Sat, 17 Mar 2007 06:10:28 GMT
This is awesome Ole but I ran into some problems ...

I tried building the project at the SVN URL but I could not get it to build.

Looks like several required dependency poms could not be found.  Perhaps
there is an issue wrt the repository it is using?


On 3/16/07, Ole Ersoy <> wrote:
> Hey Guys,
> I uploaded the RPM factory and supporting projects to my sandbox.
> I have run it on a pretty sizable portion of a locally mirrored maven
> repository,
> and it's pretty solid.  Once in a while there is a hick up if a pom has
> invalid elements...
> If anyone is itching to use it I can walk you through the install.
> From 50K feet, you just need to:
> -  locally mirror the maven repository
> - Take a chunk of it that you want to RPM and put it in a directory
> - Run the RPM factory archetype to create a sample project
> - Point the RPM Factory Archetype project repository base parameter to
> the directory containing the portion of the maven respository that you
> want to RPM
> - Run this: mvn org.apache.maven:rpm.factory.mojo:1.0-SNAPSHOT:generate
> And it a short while you will have a bunch of RPMs in the Archetype
> Project's src/main/resources/build/rpm/RPMS directory.
> The factory filters SNAPSHOTS and pom's without licenses, so RPMs for
> these won't show up.
> Hope to have the Daemon and Classloader configuration understood and
> redone soon, so that we can setup a Yum repository for the
> RPM installer.
> Have a terrific weekend everybody,
> - Ole

View raw message