directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre-Arnaud Marcelot">
Subject Re: [Studio] [Mavenization] Exception when running the studio:eclipse task
Date Mon, 07 Jan 2008 13:48:57 GMT
Thanks for fixing this, Felix.

I can now run the studio:eclipse task without errors. :D

I tried to import the projects in Eclipse and I got two problems.

First, the .project file situated at the root of your sandbox is hidding the
projects underneath (i.e. all our projects actually). So to be able to
import our projects, I had to delete it before.
Is this file useful ? Can we remove it ?

Secondly, I was not able to import all the projects... We the current naming
scheme, we have several projects with the same project name (e.g. becomes project 'core' in
Eclipse, same thing with
I think we should change our project scheme and use '' as groupId in all our project. Then, we could
set the artifactId with the remaining part of the project name. E.g. the
LDAP Browser Core project would have '' as
groupId and 'ldapbrowser.core' as artifactId. This will prevent us from
having import problems in Eclipse.


On Jan 7, 2008 1:33 PM, Felix Knecht <> wrote:

> Hi Pierre-Arnaud
> > On Jan 7, 2008 12:05 PM, Felix Knecht <
> > <>> wrote:
> >
> >     I thought having fixed this some time ago.
> >
> >     Can you try to re-install locally the latest studio-plugin and try
> >     again?
> >
> >
> > Hi Felix,
> >
> > I already tried it (on Mac OS and Linux) and I got the same result.
> Found it. I only fixed it have the way down at the time. Sorry for the
> troubles and thanks for testing!
> Regards
> Felix

View raw message