directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Randall (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-989) Eclipse Luna Integration
Date Thu, 26 Feb 2015 06:27:05 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-989?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14337968#comment-14337968
] 

Brett Randall commented on DIRSTUDIO-989:
-----------------------------------------

I was also unable to install under Luna.  I tried the workaround mentioned by Kelly for 2.0-style
plugins, but that did not work.

I am getting these OSGi errors:

{code}
org.osgi.framework.BundleException: Could not resolve module: org.apache.directory.studio.valueeditors
[1102]
  Unresolved requirement: Require-Bundle: org.apache.directory.studio.ldapbrowser.common
    -> Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.common; bundle-version="2.0.0.v20130628";
singleton:="true"
       org.apache.directory.studio.ldapbrowser.common [1086]
         Unresolved requirement: Require-Bundle: org.apache.directory.studio.ldapbrowser.core
           -> Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.core; bundle-version="2.0.0.v20130628";
singleton:="true"
              org.apache.directory.studio.ldapbrowser.core [1087]
                No resolution report for the bundle.  Unresolved requirement: Require-Bundle:
org.apache.directory.studio.ldapbrowser.core
    -> Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.core; bundle-version="2.0.0.v20130628";
singleton:="true"
  Bundle was not resolved because of a uses contraint violation.
  org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve
resource org.apache.directory.studio.ldapbrowser.core [osgi.identity; osgi.identity="org.apache.directory.studio.ldapbrowser.core";
type="osgi.bundle"; version:Version="2.0.0.v20130628"; singleton:="true"] because it is exposed
to package 'org.apache.commons.collections' from resources org.apache.commons.collections
[osgi.identity; osgi.identity="org.apache.commons.collections"; type="osgi.bundle"; version:Version="3.2.1"]
and org.apache.commons.collections [osgi.identity; osgi.identity="org.apache.commons.collections";
type="osgi.bundle"; version:Version="3.2.0.v2013030210310"] via two dependency chains.

Chain 1:
  org.apache.directory.studio.ldapbrowser.core [osgi.identity; osgi.identity="org.apache.directory.studio.ldapbrowser.core";
type="osgi.bundle"; version:Version="2.0.0.v20130628"; singleton:="true"]
    require: (&(osgi.wiring.bundle=org.apache.commons.collections)(bundle-version>=3.2.1))
     |
    provide: osgi.wiring.bundle: org.apache.commons.collections
  org.apache.commons.collections [osgi.identity; osgi.identity="org.apache.commons.collections";
type="osgi.bundle"; version:Version="3.2.1"]

Chain 2:
  org.apache.directory.studio.ldapbrowser.core [osgi.identity; osgi.identity="org.apache.directory.studio.ldapbrowser.core";
type="osgi.bundle"; version:Version="2.0.0.v20130628"; singleton:="true"]
    require: (&(osgi.wiring.bundle=org.apache.directory.api.ldap.codec.core)(bundle-version>=1.0.0.M19))
     |
    provide: osgi.wiring.bundle; osgi.wiring.bundle="org.apache.directory.api.ldap.codec.core";
bundle-version:Version="1.0.0.M19"
  org.apache.directory.api.ldap.codec.core [osgi.identity; osgi.identity="org.apache.directory.api.ldap.codec.core";
type="osgi.bundle"; version:Version="1.0.0.M19"]
    import: (&(osgi.wiring.package=org.apache.directory.api.ldap.model.message)(&(version>=1.0.0)(!(version>=2.0.0))))
     |
    export: osgi.wiring.package=org.apache.directory.api.ldap.model.message; uses:=org.apache.commons.collections
  org.apache.directory.api.ldap.model [osgi.identity; osgi.identity="org.apache.directory.api.ldap.model";
type="osgi.bundle"; version:Version="1.0.0.M19"]
    import: (&(osgi.wiring.package=org.apache.commons.collections)(&(version>=3.2.0)(!(version>=4.0.0))))
     |
    export: osgi.wiring.package: org.apache.commons.collections
  org.apache.commons.collections [osgi.identity; osgi.identity="org.apache.commons.collections";
type="osgi.bundle"; version:Version="3.2.0.v2013030210310"]
	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
{code}

> Eclipse Luna Integration
> ------------------------
>
>                 Key: DIRSTUDIO-989
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-989
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-rcp
>    Affects Versions: 2.0.0-M8 (2.0.0.v20130628)
>         Environment: Windows 8.1, Java 7_60, Eclipse Luna
>            Reporter: Kelly Ferrone
>              Labels: build, features
>             Fix For: 2.0.0-M8 (2.0.0.v20130628)
>
>
> I successfully installed every plugin except the RCP feature which complained about missing
dependencies which should exist so I think it wanted maybe an older version. Also the the
perspective is missing along with every view except the LDAP server view which did surprisingly
turn ApacheDS on and off just fine. I did successfully install every component into Keplar
just fine so I know it has something to do with Luna. 
> Here is the error I get during installing the RCP feature:
> Cannot complete the install because one or more required items could not be found.
> Software currently installed: Apache Directory Studio RCP 2.0.0.v20130628 (org.apache.directory.studio.rcp.feature.feature.group
2.0.0.v20130628)
> Missing requirement: Apache Directory Studio RCP 2.0.0.v20130628 (org.apache.directory.studio.rcp
2.0.0.v20130628) requires 'bundle org.eclipse.update.core 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: Apache Directory Studio RCP 2.0.0.v20130628 (org.apache.directory.studio.rcp.feature.feature.group
2.0.0.v20130628)
> To: org.apache.directory.studio.rcp [2.0.0.v20130628] 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message