directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (DIRSERVER-2073) Unable to make SSL connection on Oracle java 6 for ApacheDS 2.0.0-M19
Date Wed, 24 Jun 2015 11:14:04 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-2073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14599255#comment-14599255
] 

Emmanuel Lecharny edited comment on DIRSERVER-2073 at 6/24/15 11:14 AM:
------------------------------------------------------------------------

Simply because that would put the client at risk. At some point, you have to face the reality
: if teh client is weak, it has to be changed. It happened with browsers already.

But here, the point is that we don't want to deal with older version of Java, just because
some users want to keep going with it : it's the open door to problem that would fall on us,
something we don't want. Bottom line, we started the project when Java 4 get out, and we decided
to move on with Java 5 only years later, then Java 6 and now Java 7, which is btw already
EOLed too.

You guys can't simply use a piece of software that is dead and buried. More important, you
can't ask us to maintain *our* project with a version we don't want to support just because
you needed it. It takes time we don't have. As I already said : this is an Open Source project,
you are free to fork it and patch it to fit your requirements. We won't do that.


was (Author: elecharny):
Simply because that would put the client at risk. At some point, you have to face the reality
: if teh client is weak, it has to be changed. It happened with browsers already.

But here, the point is that we don't want to deal with older version of Java, just because
some users want to keep going with it : it's the open door to problem that would fall on us,
something we don't want. Bottom line, we started the project when Java 4 get out, and we decided
to move on with Java 5 only years later, then Java 6 and now Java 7, which is btw already
EOLed too.

You guys can't simply use a piece of software that is dead and buried. More important, you
can't ask us to maintain *our* project with a version we don't want to support just because
you needed it. It takes time we don't have. As I alre

> Unable to make SSL connection on Oracle java 6 for ApacheDS 2.0.0-M19
> ---------------------------------------------------------------------
>
>                 Key: DIRSERVER-2073
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-2073
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M19
>         Environment: Oracle jdk 1.6.0_45
>            Reporter: Martin Choma
>              Labels: security
>
> TLSv1.1 is not provided for Oracle JDK 1.6, which is used by ApacheDS 2.0.0-M19
> Is there a way to specify, that I want to use TLSv1.0 instead of default TLSv1.1 in ApacheDS
2.0.0-M19? 
>         at org.apache.mina.core.filterchain.DefaultIoFilterChain.register(DefaultIoFilterChain.java:383)
>         at org.apache.mina.core.filterchain.DefaultIoFilterChain.addLast(DefaultIoFilterChain.java:189)
>         at org.apache.mina.core.filterchain.DefaultIoFilterChainBuilder.buildFilterChain(DefaultIoFilterChainBuilder.java:436)
>         at org.apache.mina.core.polling.AbstractPollingIoProcessor.addNow(AbstractPollingIoProcessor.java:532)
>         at org.apache.mina.core.polling.AbstractPollingIoProcessor.handleNewSessions(AbstractPollingIoProcessor.java:505)
>         at org.apache.mina.core.polling.AbstractPollingIoProcessor.access$400(AbstractPollingIoProcessor.java:67)
>         at org.apache.mina.core.polling.AbstractPollingIoProcessor$Processor.run(AbstractPollingIoProcessor.java:1113)
>         at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:64)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
>         at java.lang.Thread.run(Thread.java:662)
> Caused by: java.lang.IllegalArgumentException: TLSv1.1
>         at com.sun.net.ssl.internal.ssl.ProtocolVersion.valueOf(ProtocolVersion.java:133)
>         at com.sun.net.ssl.internal.ssl.ProtocolList.<init>(ProtocolList.java:38)
>         at com.sun.net.ssl.internal.ssl.SSLEngineImpl.setEnabledProtocols(SSLEngineImpl.java:1821)
>         at org.apache.mina.filter.ssl.SslHandler.init(SslHandler.java:176)
>         at org.apache.mina.filter.ssl.SslFilter.onPreAdd(SslFilter.java:426)
>         at org.apache.mina.core.filterchain.DefaultIoFilterChain.register(DefaultIoFilterChain.java:381)
>         ... 10 more



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message