directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Burgemeister (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRSTUDIO-1061) RawSchemaDefinition always shows single hyphen/dash (empty) for attributes or classes
Date Fri, 26 Jun 2015 17:13:04 GMT
Aaron Burgemeister created DIRSTUDIO-1061:
---------------------------------------------

             Summary: RawSchemaDefinition always shows single hyphen/dash (empty) for attributes
or classes
                 Key: DIRSTUDIO-1061
                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1061
             Project: Directory Studio
          Issue Type: Bug
          Components: studio-schemaeditor
    Affects Versions: 2.0.0-M9 (2.0.0.v20150606-M9)
         Environment: openSUSE 13.1 x86_64
NetIQ eDirectory 8.8 SP8 backend
OpenLDAP backend
ApacheDS 2.0.0 (within Apache Directory Studio)
            Reporter: Aaron Burgemeister


A part of Apache Directory Studio I use a fair bit is the view of the RawSchemaDefinition
within the Schema Editor.  Attempting to use this in M9 (where I'm 99.99% sure it worked in
M8, or whatever the previous public milestone was from 2013) yields nothing but the hyphen/dash
that indicates nothing is there.

Steps to duplicate:
Point to a directory (ldap.forumsys.com:389 is public and duplicates the problem)
Click on Root DSE
LDAP (menu): Open Schema Editor
Click on any class or attribute and attempt to get information when expanding the RawSchemaDefinition
field.

Expected Results: Show the raw schema definition.

Actual Results: No raw schema definition anymore.

Reproducible: Always

I pointed to three different types of servers in case something was amiss with one of their
schema representations, but all of them exhibit the same symptom, including the built-in ApacheDS
instance that I created anew in Studio M9.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message