directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-1115) Value editor settings are not used and the menu displays wrong entries
Date Wed, 14 Sep 2016 21:49:20 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-1115?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15491540#comment-15491540
] 

Stefan Seelmann commented on DIRSTUDIO-1115:
--------------------------------------------

The issue with wrong menu item text is fixed: http://svn.apache.org/viewvc?rev=1760781&view=rev

The other issue with value editor settings are not working: you write about your custom attribute
"vacationInfo octet stream", do you mean it uses "Octet String" syntax? In such a case when
the value contains binary data or non-printable characters, then I'm able to reproduce your
issue. For example if I assign the "Text Editor" to the "userCertificate" attribute, then
on double-click nothing happens, only the Hex-Editor works. There is some design flow how
the value editors work, it's possible to assign each value editor to every attribute, and
if a value cannot be parsed most of the value editors just do nothing, not even give an error.
I'll look if it's possible to change that and at least open an error dialog or so.

> Value editor settings are not used and the menu displays wrong entries
> ----------------------------------------------------------------------
>
>                 Key: DIRSTUDIO-1115
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1115
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-ldapbrowser
>    Affects Versions: 2.0.0-M10 (2.0.0.v20151221-M10)
>         Environment: Windows 7 x64
> Linux Debian 8.5 x64
>            Reporter: Nagy Attila
>            Priority: Minor
>
> The following two issues are really close related to each other, so I'm reporting them
here together. If they should be reported separately, then please indicate so, and I'll separate
them.
> I was trying to set custom value editor for some attributes (vacationInfo octet stream)
when I discovered that the settings are ignored. I added a new entry into Value Editors (Eclipse
Preferences -> LDAP Browser -> Value Editors):
> attribute: vacationInfo
> value editor: "Text Editor"
> Applied the settings (even restarted Eclipse) but on double clicking a vacationInfo attribute
nothing happens, not even if I right click and select "Edit Value". The only way to edit the
attribute value is to right click the attribute, select "Edit Value With" and there selecting
"Hex Editor".
> While I was messing with these settings I noticed that the "Edit Value With" submenu
contains a changing entry (top one, besides the alternative editors and the "Preferences..."
one) which as I found out is the entry corresponding to the previously selected attribute.
So if selecting a password, afterwards selecting a string attribute  and then looking into
the "Edit Value With" submenu, it will contain a "Password Editor" entry which will do nothing.
And sometimes it does really weird things.
> Eg:
> Selecting a Boolean and afterwards a Password: the "Boolean Editor" entry is displayed
but it opens the "Password Editor".
> Selecting a Password and afterwards a Boolean: the "Password Editor" entry is displayed
but it opens the "In-Place text Editor".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message