directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <>
Subject [jira] (DIRSERVER-2116) ApacheDS failed to start after every reboot and throwing error ERR_250_ENTRY_ALREADY_EXISTS dc=example,dc=com already exists!
Date Tue, 31 Jan 2017 18:47:51 GMT


Emmanuel Lecharny commented on DIRSERVER-2116:

ApacheDS itself require some loves in many areas, but mainly on replication, ACLs and administrative
model. It's tricky, and requires quite a lot of mojo (aka, understanding the ApacheDS internals).
Not sure that would be the starting point.

Mavibot is currenlty in active development. As I said, I rebooted the effort a few weeks ago,
and I now have a code that is 4x faster for updates than the latest released Mavibot version,
but it's also buggy and non complete yet, but I'm confident I can get it done in a few weeks
(and that will solve many of the issues we currently have, including yours).

Studio is different : it relies on the LDAP API, which is almost code complete, and has a
modular architcture. That would be a good starting point for someone wanting to give a hand.

Now, the thing is that we started to work on a configuration editor for OpenLDAP, which is
currently half backed (ie, most of the generic eements are already working, but we have to
complete teh ACL parts, and not all the modules/overlays are supported). It's not included
in any release, but it's available in the source code. I can give a hand, as I worked on this
part (please have a loo at

And, *disclaimer*, I work with the OpenLDAP people, so I can also give an hand in this area.
OpenLDAP is not user friendly, but it's usable. It's fast, it's rock solid, too. IMO, ApacheDS
is to OpenLDAP what tomcat was to Websphere a decade ago. We developped it so that it gives
a very good compatible LDAP server, easy to start, good for testing purpose, and easy to migrate
to OpenLDAP in production later on - and eventually keep it in production if it's enough for
the applications need -. You can see that Tomcat is now used in production, because it's enough
most of the time : same thing for ApacheDS, but we are not as solid as Tomcat is now.

Regarding 1.5, no, its dead. And it's not enymore solid than 2.0.0-M23. The thing is that
we made a mistake 10 years ago, when we switched from Java 1.4 to Java 5 : we decided to use
a x.5 number to reflect tis change (pretty much what tomcat with 5.5). We kept going up to
1.5.7, then decided that it was stupid, and switched to Milestones, ie, 1.5.7 -> 2.0.0-M1.

But you can play with 1.5, if you like :-)

> ApacheDS failed to start after every reboot and throwing error ERR_250_ENTRY_ALREADY_EXISTS
dc=example,dc=com already exists!
> -----------------------------------------------------------------------------------------------------------------------------
>                 Key: DIRSERVER-2116
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M21
>         Environment: Ubuntu 14.04.3 LTS trusty
>            Reporter: AADI
>             Fix For: 2.0.0-M24
> HI 
> I downloaded ApcheDS Debian Package (apacheds-2.0.0-M21-amd64.deb ) 
> and installed on Ubuntu server for my personal testing of LDAP .
> It worked very well after i installed and configured on my server .
> But problems arise when my server rebooted every-time . 
> After every reboot i have to start the  ApacheDS server manually  by follwing command

> *sudo /etc/init.d/apacheds-2.0.0-M21-default start
> And immediately i got following reply 
> Starting ApacheDS - default...
> ApacheDS - default is already running. *
> But this is not true. i observed there is no process running which are associated with
ApacheDS  in OS 
> After referring the one of the solution given in this list i just clear the pid file
contents ( /var/lib/apacheds-2.0.0-M21/default/run/ and overcome the
first problem .
> But still it failed to start and i observed below errors in log file 
> {color:red}
> {{jvm 1    | [15:51:29] ERROR []
- Failed to start the service.
dc=example,dc=com already exists!
> jvm 1    | 	at
> jvm 1    | 	at
> jvm 1    | 	at
> jvm 1    | 	at
> jvm 1    | 	at
> jvm 1    | 	at
> jvm 1    | 	at org.tanukisoftware.wrapper.WrapperManager$
> i would like to know that should i reinstall the ApacheDS evertyime when server reboot
> i tried several solutions mentioned in web to overcome this none worked for me except

This message was sent by Atlassian JIRA

View raw message