directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Javier A. Ortiz (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRSERVER-2227) Unable to start on Mac
Date Thu, 22 Mar 2018 14:49:00 GMT
Javier A. Ortiz created DIRSERVER-2227:
------------------------------------------

             Summary: Unable to start on Mac
                 Key: DIRSERVER-2227
                 URL: https://issues.apache.org/jira/browse/DIRSERVER-2227
             Project: Directory ApacheDS
          Issue Type: Bug
          Components: core
            Reporter: Javier A. Ortiz


On each start up I get this error:
{noformat}
java.version=9.0.4

java.vendor=Oracle Corporation

BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US

Framework arguments:  /studio-rcp/resources/icons/linux/studio.xpm -keyring /Users/javierortiz/.eclipse_keyring
-showlocation

Command-line arguments:  -os macosx -ws cocoa -arch x86_64 /studio-rcp/resources/icons/linux/studio.xpm
-keyring /Users/javierortiz/.eclipse_keyring -showlocation



!ENTRY org.apache.directory.api.ldap.codec.core 4 0 2018-03-22 09:15:26.916

!MESSAGE FrameworkEvent ERROR

!STACK 0

org.osgi.framework.BundleException: Could not resolve module: org.apache.directory.api.ldap.codec.core
[33]

  Unresolved requirement: Import-Package: org.apache.directory.api.asn1; version="1.0.0.M33"

    -> Export-Package: org.apache.directory.api.asn1; bundle-symbolic-name="org.apache.directory.api.asn1.api";
bundle-version="1.0.0.M33"; version="1.0.0.M33"

       org.apache.directory.api.asn1.api [27]

         Unresolved requirement: Import-Package: org.apache.directory.api.i18n; version="1.0.0.M33"
                                                      
           -> Export-Package: org.apache.directory.api.i18n; bundle-symbolic-name="org.apache.directory.api.i18n";
bundle-version="1.0.0.M33"; version="1.0.0.M33"

              org.apache.directory.api.i18n [31]

                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"



        at org.eclipse.osgi.container.Module.start(Module.java:434)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)

        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
{noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message