directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (DIRSERVER-2246) DS does not answer search request which contains attribute jpegPhoto
Date Sat, 18 Aug 2018 21:13:00 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-2246?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16584926#comment-16584926
] 

Emmanuel Lecharny edited comment on DIRSERVER-2246 at 8/18/18 9:12 PM:
-----------------------------------------------------------------------

Wait, I totally missed the remaining logs...

So there is a second search after a second successful bind (user {{uid=phone,ou=utenti,dc=smabit}})
:
* baseDN: dc=smabit
* scope = SUBTREE
* filter: (|)

{noformat}
30 44         // Ldap Message, mength 68
  02 01 02  // Message ID = 2
  63 3f        // SearchRequest, length = 63
    04 09     // Base object = dc=smabit
      64 63 3d 73  6d 61 62 69 74 dc=smabit
    0a 01 02 // scope SUBTREE
    0a 01 00 // derefalias NEVER
    02 02 00 32 // SizeLimit 50
    02 01 00  // Time limit 0
    01 01 00 // TypesOnly false
    a1 00 // Empty OR filter ???
    30 20 // AttributeDescriptio nList
      ...
{noformat}

Here, the problem is that the filter is invalid: it's empty.

There is no search response sent, but I don't know if it's because the server never sent any,
or because the logs does not contain any.

Basically, the search Request is wrong (empty filter), but I can check if the server behave
properly with such a request (ie sending a noticeOfDisconnect).


was (Author: elecharny):
Wait, I totally missed the remaining logs...


> DS does not answer search request which contains attribute jpegPhoto
> --------------------------------------------------------------------
>
>                 Key: DIRSERVER-2246
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-2246
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: ldap
>    Affects Versions: 2.0.0-M24
>            Reporter: Peter Hoyer
>            Priority: Major
>         Attachments: trace.pcapng
>
>
> I am trying to connect a Snom with with an Apache DS LDAP server.
> The problem is that the phone, if you do not specify any additional parameters, will
include the attributes cn, telephoneNumber, jpegPhoto in the serach. Result is that the server
does not answer the search request at all.
> Is there any way to convince the server to ignore unknown attributes in the search request?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message