directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRAPI-324) commons-lang and commons-collections need to be updated to most recent versions
Date Fri, 16 Nov 2018 15:13:00 GMT

    [ https://issues.apache.org/jira/browse/DIRAPI-324?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16689540#comment-16689540
] 

ASF GitHub Bot commented on DIRAPI-324:
---------------------------------------

smoyer64 commented on issue #3: [DIRAPI-324] commons-lang and commons-collections are updated
URL: https://github.com/apache/directory-ldap-api/pull/3#issuecomment-439423332
 
 
   @elecharny I've been working with JUnit 5 for a couple years and I'm also part of a team
that's building community tooling to enhance the core engine.  We have a conversion tool that
for certain types of tests can do most of the conversion.  I ran this tool for the commons-lang
project and with a few exceptions it was mostly successful (the new version of ``@Test`` doesn't
have an ``expected`` attribute.  This conversion was declined (https://github.com/apache/commons-lang/pull/353)
because the team wanted to refactor/optimize the test code while updating to JUnit 5.  If
you're only interested in the tests being converted to JUnit 5 at this point, I'd be happy
to give the tool a try on our codebase (or you can of course).
   
   The pseudo-official community curated project is [JUnit Pioneer](https://github.com/junit-pioneer/junit-pioneer)
and the converter code was recently donated as a separate project by @boyarski - https://github.com/junit-pioneer/convert-junit4-to-junit5.
 Let me know if you'd like some help with this!

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> commons-lang and commons-collections need to be updated to most recent versions
> -------------------------------------------------------------------------------
>
>                 Key: DIRAPI-324
>                 URL: https://issues.apache.org/jira/browse/DIRAPI-324
>             Project: Directory Client API
>          Issue Type: Dependency upgrade
>    Affects Versions: 2.0.0.AM2
>            Reporter: Maxim Solodovnik
>            Priority: Major
>             Fix For: 2.0.0.AM3
>
>
> commons-lang and commons-collections need to be updated to most recent versions



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message