directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-1199) 2.0.0-M14 doesn't display objectGUID / objectSid correctly
Date Sat, 03 Nov 2018 14:56:00 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-1199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16674072#comment-16674072
] 

Stefan Seelmann commented on DIRSTUDIO-1199:
--------------------------------------------

The data from the server is read in {{org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper}}
(for LDAP API) or {{org.apache.directory.studio.connection.core.io.jndi.JNDIConnectionWrapper}}
(for JNDI), within the {{search}} method.

I can imagine it has to do with the detection of binary attributes. In the preferences objectGUID
and objectSid are defined as binary attributes. Maybe that information is lost somewhere.

> 2.0.0-M14 doesn't display objectGUID / objectSid correctly
> ----------------------------------------------------------
>
>                 Key: DIRSTUDIO-1199
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1199
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-ldapbrowser
>    Affects Versions: 2.0.0-M14
>         Environment: Linux, Debian 9.5, Samba 4.5.12
>            Reporter: Samo
>            Priority: Major
>         Attachments: m13.png, m14.png
>
>
> In Apache Directory Studio _2.0.0-M14_ *objectGUID* is displayed as "Invalid GUID", *objectSid*
as "Invalid SID" for a Samba 4 AD. In Apache Directory Studio _2.0.0-M13_ both attributes
are displayed correctly, as seen on screenshots.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message