directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lothar Haeger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-1199) 2.0.0-M14 doesn't display objectGUID / objectSid correctly
Date Sat, 10 Nov 2018 16:52:00 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-1199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16682505#comment-16682505
] 

Lothar Haeger commented on DIRSTUDIO-1199:
------------------------------------------

Did a little more debugging and it's easy to follow the code using JNDI, where I see the GUID
being returned as 16 bytes. Not so with the Directory API, where all I see is a cursor but
not the actual attribute contents. Seems like I do not quite get the way this is meant to
work yet.

Anyway, I'm off for the next two weeks, so maybe someone knowing the code better could have
a look, too....

> 2.0.0-M14 doesn't display objectGUID / objectSid correctly
> ----------------------------------------------------------
>
>                 Key: DIRSTUDIO-1199
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1199
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-ldapbrowser
>    Affects Versions: 2.0.0-M14
>         Environment: Linux, Debian 9.5, Samba 4.5.12
>            Reporter: Samo Forus
>            Priority: Major
>         Attachments: m13.png, m14.png
>
>
> In Apache Directory Studio _2.0.0-M14_ *objectGUID* is displayed as "Invalid GUID", *objectSid*
as "Invalid SID" for a Samba 4 AD. In Apache Directory Studio _2.0.0-M13_ both attributes
are displayed correctly, as seen on screenshots.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message