directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRAPI-328) Fix inconsistency in Attribute and Value
Date Sun, 25 Nov 2018 13:17:00 GMT
Stefan Seelmann created DIRAPI-328:
--------------------------------------

             Summary: Fix inconsistency in Attribute and Value
                 Key: DIRAPI-328
                 URL: https://issues.apache.org/jira/browse/DIRAPI-328
             Project: Directory Client API
          Issue Type: Improvement
            Reporter: Stefan Seelmann
            Assignee: Stefan Seelmann
             Fix For: 2.0.0.AM3


Inconsistent method names:
* Attribute: getString() and getBytes()
* Value: getValue() and getBytes()
* Proposal: Rename Value.getValue() to Value.getString()

Inconsistent and wrong documented error handling:
* Attribute: getString() and getBytes() check for isHumanReadable and throw LdapInvalidAttributeValueException
* Value: getValue()/getString() tries to UTF-8 encode bytes if not human readable, which doesn't
work always, and javadoc says "returns null"
* Value: getBytes() doesn't check if is human readable
* Proposal: Make Value behave like Attribute, i.e. throw LdapInvalidAttributeValueException

Opinions?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message