directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruchi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRSTUDIO-1212) Check Network Parameter button throws error
Date Tue, 12 Feb 2019 22:19:00 GMT
Ruchi created DIRSTUDIO-1212:
--------------------------------

             Summary: Check Network Parameter button throws error
                 Key: DIRSTUDIO-1212
                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1212
             Project: Directory Studio
          Issue Type: Bug
            Reporter: Ruchi


Once we create connection for LDAP server, the first step where we provide ldap host and port
and then try to "Check Network Parameter" by pressing this button, it throws error:

 

 

!STACK 0

java.lang.Exception: Unable to connect

        at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper$1.run(DirectoryApiConnectionWrapper.java:251)

        at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.runAndMonitor(DirectoryApiConnectionWrapper.java:1312)

        at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.doConnect(DirectoryApiConnectionWrapper.java:281)

        at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.connect(DirectoryApiConnectionWrapper.java:172)

        at org.apache.directory.studio.connection.core.jobs.CheckNetworkParameterRunnable.run(CheckNetworkParameterRunnable.java:80)

        at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:140)

        at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)

 

 

Some how network connection to ldap host cannot be tested. 

But next step where we provide, ldap user/password, we can check the authentication successful.

 

Even ldap entries can be browsed in the studio.

 

Only problem is " Check Network Parameter" button throws above error to check the network
connection and gives false alarm.

 

Is there a quick fix that I can do in my local environment?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message