directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DIRSERVER-2042) Replication with StartTLS doesnt appear to work
Date Fri, 28 Jun 2019 06:34:00 GMT

     [ https://issues.apache.org/jira/browse/DIRSERVER-2042?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Emmanuel Lecharny updated DIRSERVER-2042:
-----------------------------------------
    Component/s:     (was: ldap)
                 replication
                 network

> Replication with StartTLS doesnt appear to work
> -----------------------------------------------
>
>                 Key: DIRSERVER-2042
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-2042
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: network, replication
>    Affects Versions: 2.0.0-M16, 2.0.0-M19
>         Environment: Linux/CentOS
>            Reporter: GregF
>            Priority: Major
>
> Using ApacheDS replication using StartTLS doesn't seem to establish a secure connection.
There is not much documentation available, but I have ads-replusetls set to TRUE. Watching
the network traffic, the replication user's bind credentials seem to be transmitted in plaintext.
Further traffic is also clearly readable. I don't believe StartTLS is being used.Is there
anything additional I need to do to make things work. Issue seems to exist in M16 and M19.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@directory.apache.org
For additional commands, e-mail: dev-help@directory.apache.org


Mime
View raw message