directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "HeYuejin (Jira)" <>
Subject [jira] [Commented] (DIRSERVER-2235) After renaming an entry in ApacheDS, the directory loses the new entry
Date Thu, 28 May 2020 06:43:00 GMT


HeYuejin commented on DIRSERVER-2235:


I ran into the same problem. The screenshot is what it looks like after rename. The rename
method is called through the springLdap framework. After the call, it is checked in ApacheDirectoryStudio.
After the move, the attribute of the entry is blank. Restart the LDAP service, or wait for
about 20 minutes and restart Refresh the entry, the entry will be displayed


> After renaming an entry in ApacheDS, the directory loses the new entry
> ----------------------------------------------------------------------
>                 Key: DIRSERVER-2235
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: jdbm
>    Affects Versions: 2.0.0-M20, 2.0.0-M24
>         Environment: Debian Linux, x64
>            Reporter: Roland Szabó
>            Priority: Major
>             Fix For: 2.0.0
>         Attachments: image-2020-05-28-14-34-35-460.png, image-2020-05-28-14-42-39-788.png,
> When I rename an entry in our directory, the old entry is still returned in searches
but it cannot be read. The new entry exists, but only when referred directly by its DN. I
have to restart the server to clean this mess up.
> I tried to use the rename operation in JNDI, then I switched to the ApacheDS LDAP-API,
but both method results in the same problem. We use the CN attribute as the RDN, and after
renaming, the CN attribute of the entry is all lowercase, however the DN maintains the correct
casing. If I update the CN attribute to the correct case, I can use the rename operation on
the entry 1 more time. If I also close the connection between rename operations, I can rename
the same entry 1 more time, but then it fails again.
> I tried to upgrade from M20 to M24, but the problem is still there.
> I do not really understand the reason...

This message was sent by Atlassian Jira

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message