directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From José Manuel (Jira) <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-1248) Apache Directory Studio fails to start in Catalina 10.15.4
Date Tue, 05 May 2020 13:44:00 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-1248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17099882#comment-17099882
] 

José Manuel commented on DIRSTUDIO-1248:
----------------------------------------

Sorry, I didn't see the issue was updated. I installed M15 but to no luck. Some details:

{{$ which java}}
{{/usr/bin/java}}

{{$ /usr/bin/java -version}}
{{java version "14" 2020-03-17}}
{{Java(TM) SE Runtime Environment (build 14+36-1461)}}
{{Java HotSpot(TM) 64-Bit Server VM (build 14+36-1461, mixed mode, sharing)}}

{{$ /usr/libexec/java_home -V}}
{{Matching Java Virtual Machines (2):}}
{{ 14, x86_64: "Java SE 14" /Library/Java/JavaVirtualMachines/jdk-14.jdk/Contents/Home}}
{{ 1.8.0_242, x86_64: "AdoptOpenJDK 8" /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home}}{{/Library/Java/JavaVirtualMachines/jdk-14.jdk/Contents/Home}}

{{$ ./ApacheDirectoryStudio}}
{{Error: could not find libjava.dylib}}
{{Failed to GetJREPath()}}

My macOS version is 10.15.4 (19E287).

Suposedly, I'm using the latest version of Oracle JDK... or should I use a different one?

 

> Apache Directory Studio fails to start in Catalina 10.15.4
> ----------------------------------------------------------
>
>                 Key: DIRSTUDIO-1248
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1248
>             Project: Directory Studio
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M14
>         Environment: macos Catalina 10.15.4
>            Reporter: José Manuel
>            Priority: Major
>              Labels: catalina
>         Attachments: Captura de pantalla 2020-04-15 a las 11.43.55.png, ds-java-problem.png
>
>
> Hi,
>   I have tried to run Studio in a brand new macbook with Catalina 10.15.4, but it fails
to start with message:
> My java version:
> *{{$ java -version}}*
> *{{java version "14" 2020-03-17}}*
> *{{Java(TM) SE Runtime Environment (build 14+36-1461)}}*
> *{{Java HotSpot(TM) 64-Bit Server VM (build 14+36-1461, mixed mode, sharing)}}*
> I have tried installing different java versions (and also tried installing from brew
and ports with different problems), but it won't open. I also tried latest nightly build,
which Catalina says it's corrupt...
> How could I provide more information to debug this issue?
>  
> Thanks,
> Jose.
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@directory.apache.org
For additional commands, e-mail: dev-help@directory.apache.org


Mime
View raw message