directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "D. Tervooren (Jira)" <>
Subject [jira] [Updated] (DIRSERVER-2332) Unexpected Session Termination (nslcd - libpam-ldapd
Date Sun, 20 Sep 2020 17:39:00 GMT


D. Tervooren updated DIRSERVER-2332:
    Attachment:     (was: Dockerfile.txt)

> Unexpected Session Termination (nslcd - libpam-ldapd
> ----------------------------------------------------
>                 Key: DIRSERVER-2332
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: asn1, core, ldap
>    Affects Versions: 2.0.0.AM26
>         Environment: - Raspbian Clients with nslcd
> - Apache Studio in Windows
> - ApacheDS running in Docker (self built image)
>            Reporter: D. Tervooren
>            Priority: Minor
>              Labels: NullPointerException, ldap, mina, nslcd
>         Attachments: Dockerfile.txt, capture_nslcd.pcap, capture_studio.pcap, debug.log
> I'm currently playing around with a small raspi-cluster - the intention is to have unified
LDAP login via libpam-ldapd and NFS mounted home-dirs.
> t
> While setting up libpam-ldapd together with apacheds worked like charm - during some
tests i noticed, that secondary group names don't work.
> Tinkering around with the log-levels revealed a NullPointerException
> _at
> I tried to isolate the cause of the error to build a test-case but while finding my way
through the code-base I stranded in the mina and ldap-api repo.
> I'm willing to provide every information that is needed to dive deeper into this issue.
> A Capture (pcap) of the ldap_search from nslcp aswell as (basically) the same search
from studio (which suprisingly works just fine) are attached aswell as the DEBUG log which
also contains the HEX for the network request.

This message was sent by Atlassian Jira

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message