directory-fortress mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn McKinney <smckin...@apache.org>
Subject Re: [Bulk] problem deploying fortress-rest
Date Tue, 21 Apr 2015 13:37:36 GMT

> On Apr 21, 2015, at 5:25 AM, Oleksandr Bodriagov (Polystar) <oleksandr.bodriagov@polystar.com>
wrote:
> 
> For some reason I cannot deploy target/fortress-rest.war in Tomcat 8.0.21.
> I tried doing it manually by copying target/fortress-rest.war to webapps
> in Tomcat because "mvn tomcat:deploy² returns
> 
> [ERROR] Failed to execute goal
> org.codehaus.mojo:tomcat-maven-plugin:1.1:deploy (default-cli) on project
> fortress-rest: Cannot invoke Tomcat manager: Error writing to server ->
> [Help 1]
> 
> If I do it manually I get the following error in catalina logs:
> 
> 21-Apr-2015 12:15:48.625 INFO [localhost-startStop-2]
> org.apache.catalina.startup.HostConfig.deployWAR Deploying web application
> archive /usr/local/apache-tomcat-8.0.21/webapps/fortress-rest.war
> 21-Apr-2015 12:15:48.629 WARNING [localhost-startStop-2]
> org.apache.tomcat.util.digester.SetPropertiesRule.begin
> [SetPropertiesRule]{Context/Realm} Setting property 'debug' to '0' did not
> find a matching property.
> 21-Apr-2015 12:15:48.630 WARNING [localhost-startStop-2]
> org.apache.tomcat.util.digester.SetPropertiesRule.begin
> [SetPropertiesRule]{Context/Realm} Setting property 'resourceName' to
> 'UserDatabase' did not find a matching property.
> 

From the error it looks like there are properties mapped from context.xml that conflict with
the runtime.  Specifically resourceName and debug.  Since fortress doesn’t use either, I
have removed them from the context.xml for fortress-rest and tested for Tomcat 8.0.18.  If
that doesn’t work let me know and I’ll try running on 8.0.21.

Thanks 

Shawn
smckinney@apache.org

Mime
View raw message