directory-fortress mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oleksandr Bodriagov (Polystar)" <oleksandr.bodria...@polystar.com>
Subject Re: fortress rpm and tomcat deployment problem
Date Tue, 16 Jun 2015 13:13:29 GMT
Thanks Shawn! I have totally missed it!

/Oleksandr


On 16/6/2015 15:09 , "Shawn McKinney" <smckinney@apache.org> wrote:

>
>> On Jun 16, 2015, at 5:06 AM, Oleksandr Bodriagov (Polystar)
>><oleksandr.bodriagov@polystar.com> wrote:
>> 
>> Hi,
>> 
>> I would be very grateful if someone could help me with the following
>> fortress-tomcat deployment problem.
>> We have created a project that takes released fortress-web and
>> fortress-rest and makes rpm that deploys these applications on tomcat.
>>The
>> deployment does not succeed because of the error described below.
>> What could be the cause?
>> 
>> /Oleksandr
>> 
>> 
>> 16-Jun-2015 09:56:10.692 INFO [localhost-startStop-1]
>> org.apache.catalina.startup.HostConfig.deployWAR Deploying web
>>application
>> archive 
>> 
>>/opt/polystar/fortress/apache-tomcat-8.0.22/webapps/fortress-web-1.0.6.wa
>>r
>> 16-Jun-2015 09:56:10.723 SEVERE [localhost-startStop-1]
>> org.apache.tomcat.util.digester.Digester.startElement Begin event threw
>> exception
>> java.lang.ClassNotFoundException:
>> org.apache.directory.fortress.realm.tomcat.Tc7AccessMgrProxy
>> 	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
>> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
>> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
>> 	at 
>
>Hey Oleksandr, did you perform step 3 as described here?
>
>https://directory.apache.org/fortress/gen-docs/latest/apidocs/org/apache/d
>irectory/fortress/core/doc-files/apache-tomcat.html
>
>Shawn
>smckinney@apache.org


Mime
View raw message