directory-fortress mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Pike <clp...@psu.edu>
Subject Re: Static Config Initialization Problems
Date Tue, 26 Apr 2016 20:32:47 GMT
Yeah, looks like running from the command line is causing infinite loop. Is the command line
"mvn -Dtest=FortressJUnitTest test" still using ant?



----- Original Message -----
From: "Chris Pike" <clp207@psu.edu>
To: fortress@directory.apache.org
Sent: Tuesday, April 26, 2016 4:16:15 PM
Subject: Re: Static Config Initialization Problems

No, I wouldn't expect that, I've been running the tests from eclipse and don't see that happening.
I'll try running from command line and see what happens.


----- Original Message -----
From: "Shawn McKinney" <smckinney@apache.org>
To: fortress@directory.apache.org
Sent: Tuesday, April 26, 2016 4:02:34 PM
Subject: Re: Static Config Initialization Problems

> On Apr 26, 2016, at 2:26 PM, Chris Pike <clp207@psu.edu> wrote:
> 
> 
> I went ahead and refactored to not use static init blocks. There was a huge ripple effect
through the code and I ran into some other problems along the way. (had to separate out local
config from remote config and make some changes to the DAOs). 
> 
> https://github.com/PennState/directory-fortress-core-1/commits/feature/modifyBootstrapSingleton
> 
> Let me know what you think.


Built and running junit tests.  Haven’t had time to walk the initialization with a debugger
but it appears to be iterating over the same code sequences. Is this expected?  It’s generating
a lot of INFO messages.

2016-04-24 18:15:045 INFO  Config:80 - static init: load config realm [DEFAULT]
2016-04-24 18:15:045 INFO  ConfigDAO:268 - getConfig dn [cn=DEFAULT,ou=Config,dc=example,dc=com]
2016-04-24 18:15:045 INFO  LdapConnectionProvider:96 - LDAP POOL:  host=[localhost], port=[389],
min=[1], max=[10]
2016-04-24 18:15:045 INFO  Config:80 - static init: load config realm [DEFAULT]
2016-04-24 18:15:045 INFO  ConfigDAO:268 - getConfig dn [cn=DEFAULT,ou=Config,dc=example,dc=com]
2016-04-24 18:15:045 INFO  LdapConnectionProvider:96 - LDAP POOL:  host=[localhost], port=[389],
min=[1], max=[10]
2016-04-24 18:15:045 INFO  LdapConnectionProvider:96 - LDAP POOL:  host=[localhost], port=[389],
min=[1], max=[10]
2016-04-24 18:15:045 INFO  LdapConnectionProvider:96 - LDAP POOL:  host=[localhost], port=[389],
min=[1], max=[10]
2016-04-24 18:15:045 INFO  Config:80 - static init: load config realm [DEFAULT]
2016-04-24 18:15:045 INFO  ConfigDAO:268 - getConfig dn [cn=DEFAULT,ou=Config,dc=example,dc=com]
2016-04-24 18:15:045 INFO  LdapConnectionProvider:96 - LDAP POOL:  host=[localhost], port=[389],
min=[1], max=[10]
2016-04-24 18:15:045 INFO  LdapConnectionProvider:96 - LDAP POOL:  host=[localhost], port=[389],
min=[1], max=[10]
2016-04-24 18:15:045 INFO  LdapConnectionProvider:96 - LDAP POOL:  host=[localhost], port=[389],
min=[1], max=[10]
...

Mime
View raw message