directory-fortress mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn McKinney <smckin...@apache.org>
Subject Re: dir-fortress-core-docker-test failures
Date Mon, 21 Nov 2016 12:06:12 GMT


> On Nov 19, 2016, at 5:05 AM, Stefan Seelmann <mail@stefan-seelmann.de> wrote:
> 
> Strange, on my local machine it worked after I updated the Docker image
> with the new schema, see commit 68fdb84d7fa48c88ea529fa4157f703ac6f4f223
> 
> Problem on Jenkins is that it doesn't pull the new Docker image, it
> gives me "layers from manifest don't match image configuration", needs
> to be investigated...
> 

That’s actually pretty good news that the new schema works with old install.

> On Nov 19, 2016, at 5:05 AM, Stefan Seelmann <mail@stefan-seelmann.de> wrote:
> 
> Another issue on Jenkins is (which also exists on the Sonar build [1])
> is that the new Jgraph version requires Java 8 but the builds run with
> Java 7.

So I have now reverted to jgrapht 0.9.2 to eliminate this unnecessary java 8 dependency. 
That is to say eventually we should move to 8, to use lamdas, but this is not the right time.

> On Nov 19, 2016, at 5:05 AM, Stefan Seelmann <mail@stefan-seelmann.de> wrote:
>> 
>> What needs to happen is to change the docker image to use the new installation procedures
in section II:
>> https://github.com/apache/directory-fortress-core/blob/master/README-QUICKSTART-SLAPD.md
> 
> I agree, makes sense.
> 
>> I recommend turning the tests off until these changes are made.
> 
> Done.

Now I’m rethinking (again)…  

Due to my utter lack of docker competencies I am delaying the change to use the latest install
procs.  Could we give the workaround another try?  

That is to say maybe now if we reenable the jenkins tests it will work?  Assuming the other
issue (not pulling latest) can be solved.

Or, open to other ideas here.

Thanks,
Shawn


Mime
View raw message