directory-fortress mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn McKinney <smckin...@apache.org>
Subject Change service mappings to ReviewMgr authorizedUsers and authorizedRoles APIs
Date Sun, 17 Mar 2019 17:46:10 GMT
Hello,

Discovered inconsistent naming being applied to these services:

roleAuthzed -> org.apache.directory.fortress.core.impl.ReviewMgrImpl.authorizedUsers
userAuthzedn -> org.apache.directory.fortress.core.impl.ReviewMgrImpl.authorizedRoles

As you can see, they are backwards.  roleAuthzed should map to authorizedRoles API and usrAuthzedn
to authorizedUsers.

I’ve made the change to correct this inconsistency.  The code has been checked-in.  For
those deployments using these services, please adjust accordingly.  

Please let me know if you foresee any difficulties with this.

—Shawn
Mime
View raw message