drill-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From amansi...@apache.org
Subject [6/7] drill git commit: DRILL-6256: Remove references to java 7 from readme and other files
Date Fri, 30 Mar 2018 14:41:19 GMT
DRILL-6256: Remove references to java 7 from readme and other files

close apache/drill#1172


Project: http://git-wip-us.apache.org/repos/asf/drill/repo
Commit: http://git-wip-us.apache.org/repos/asf/drill/commit/03b245ef
Tree: http://git-wip-us.apache.org/repos/asf/drill/tree/03b245ef
Diff: http://git-wip-us.apache.org/repos/asf/drill/diff/03b245ef

Branch: refs/heads/master
Commit: 03b245ef4d028458fc6cc3588682d5ae9cc3bb33
Parents: 7f64556
Author: vladimir tkach <vovatkach75@gmail.com>
Authored: Mon Mar 26 20:02:37 2018 +0300
Committer: Aman Sinha <asinha@maprtech.com>
Committed: Thu Mar 29 23:23:17 2018 -0700

----------------------------------------------------------------------
 INSTALL.md                                 | 10 +++++-----
 distribution/src/resources/README.md       |  2 +-
 distribution/src/resources/drill-config.sh |  9 ++++-----
 exec/java-exec/src/main/sh/drill-config.sh |  2 +-
 exec/java-exec/src/main/sh/runbit          |  4 ++--
 pom.xml                                    |  2 +-
 6 files changed, 14 insertions(+), 15 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/drill/blob/03b245ef/INSTALL.md
----------------------------------------------------------------------
diff --git a/INSTALL.md b/INSTALL.md
index 7c65611..72268e9 100644
--- a/INSTALL.md
+++ b/INSTALL.md
@@ -3,15 +3,15 @@
 ## Prerequisites
 
 Currently, the Apache Drill build process is known to work on Linux, Windows and OSX.  To
build, you need to have the following software installed on your system to successfully complete
a build. 
-  * Java 7
+  * Java 8
   * Maven 3.x
 
 ## Confirm settings
     # java -version
-    java version "1.7.0_09"
-    Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
-    Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)
-    
+    java version "1.8.0_161"
+    Java(TM) SE Runtime Environment (build 1.8.0_161-b12)
+    Java HotSpot(TM) 64-Bit Server VM (build 25.161-b12, mixed mode)
+
     # mvn --version
     Apache Maven 3.0.3 (r1075438; 2011-02-28 09:31:09-0800)
 

http://git-wip-us.apache.org/repos/asf/drill/blob/03b245ef/distribution/src/resources/README.md
----------------------------------------------------------------------
diff --git a/distribution/src/resources/README.md b/distribution/src/resources/README.md
index 40feb29..bb1cd07 100644
--- a/distribution/src/resources/README.md
+++ b/distribution/src/resources/README.md
@@ -3,7 +3,7 @@
 ## Prerequisites
   
   * Linux, Windows or OSX 
-  * Oracle JDK 7 (JDK, not JRE)
+  * Oracle/OpenJDK 8 (JDK, not JRE)
 
 Additional requirements when running in clustered mode:
   * Hadoop 2.3+ distribution of Hadoop (such as Apache or MapR)

http://git-wip-us.apache.org/repos/asf/drill/blob/03b245ef/distribution/src/resources/drill-config.sh
----------------------------------------------------------------------
diff --git a/distribution/src/resources/drill-config.sh b/distribution/src/resources/drill-config.sh
index 55d032d..e3eaa64 100644
--- a/distribution/src/resources/drill-config.sh
+++ b/distribution/src/resources/drill-config.sh
@@ -123,10 +123,10 @@ if [ ! -e "$JAVA" ]; then
   fatal_error "Java not found at JAVA_HOME=$JAVA_HOME."
 fi
 
-# Ensure that Java version is at least 1.7
+# Ensure that Java version is at least 1.8
 "$JAVA" -version 2>&1 | grep "version" | egrep -e "1\.4|1\.5|1\.6|1\.7" > /dev/null
 if [ $? -eq 0 ]; then
-  fatal_error "Java 1.8 or later is required to run Apache Drill."
+  fatal_error "Java 1.8 is required to run Apache Drill."
 fi
 
 # Check if a file exists and has relevant lines for execution
@@ -214,9 +214,8 @@ fi
 
 export SQLLINE_JAVA_OPTS=${SQLLINE_JAVA_OPTS:-""}
 
-# Class unloading is disabled by default in Java 7
-# http://hg.openjdk.java.net/jdk7u/jdk7u60/hotspot/file/tip/src/share/vm/runtime/globals.hpp#l1622
-export SERVER_GC_OPTS="$SERVER_GC_OPTS -XX:+CMSClassUnloadingEnabled -XX:+UseG1GC"
+
+export SERVER_GC_OPTS="$SERVER_GC_OPTS -XX:+UseG1GC"
 
 # No GC options by default for SQLLine
 export CLIENT_GC_OPTS=${CLIENT_GC_OPTS:-""}

http://git-wip-us.apache.org/repos/asf/drill/blob/03b245ef/exec/java-exec/src/main/sh/drill-config.sh
----------------------------------------------------------------------
diff --git a/exec/java-exec/src/main/sh/drill-config.sh b/exec/java-exec/src/main/sh/drill-config.sh
index 20102fc..fa62da8 100644
--- a/exec/java-exec/src/main/sh/drill-config.sh
+++ b/exec/java-exec/src/main/sh/drill-config.sh
@@ -88,7 +88,7 @@ if [ -z "$JAVA_HOME" ]; then
 +======================================================================+
 |      Error: JAVA_HOME is not set and Java could not be found         |
 +----------------------------------------------------------------------+
-| Drill requires Java 1.7 or later.                                    |
+| Drill requires Java 1.8                                    |
 +======================================================================+
 EOF
     exit 1

http://git-wip-us.apache.org/repos/asf/drill/blob/03b245ef/exec/java-exec/src/main/sh/runbit
----------------------------------------------------------------------
diff --git a/exec/java-exec/src/main/sh/runbit b/exec/java-exec/src/main/sh/runbit
index 4c4aa21..0e4af4d 100755
--- a/exec/java-exec/src/main/sh/runbit
+++ b/exec/java-exec/src/main/sh/runbit
@@ -29,9 +29,9 @@ else
   exit 1
 fi
 
-$JAVA -version 2>&1 | grep "version" | egrep -e "1.7" > /dev/null
+$JAVA -version 2>&1 | grep "version" | egrep -e "1.8" > /dev/null
 if [ $? -ne 0 ]; then
-  echo "Java 1.7 is required to run Apache Drill."
+  echo "Java 1.8 is required to run Apache Drill."
   exit 1
 fi
 

http://git-wip-us.apache.org/repos/asf/drill/blob/03b245ef/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index 2d951ad..f07beaf 100644
--- a/pom.xml
+++ b/pom.xml
@@ -357,7 +357,7 @@
                   <version>[3.0.4,4)</version>
                 </requireMavenVersion>
                 <requireJavaVersion>
-                  <version>[1.7,1.9)</version>
+                  <version>[1.8,1.9)</version>
                 </requireJavaVersion>
               </rules>
             </configuration>


Mime
View raw message