drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From François Méthot <fmetho...@gmail.com>
Subject Work around for JSON type error
Date Thu, 23 Nov 2017 16:20:08 GMT
Hi,

Is there a workaround for this Jira issue:

Error: DATA_READ ERROR: Error parsing JSON - You tried to start when you
are using a ValueWriter of type NullableVarCharWriterImpl.

File /tmp/test.json
Record 2
Fragment 0:0

https://issues.apache.org/jira/browse/DRILL-4520


I tried Union with a source file and does the same issue (hoping drill
would properly set the column type form the beginning)

The only workaround I could find is to force the query to run on one thread
only and hope that the thread will be assigned a file not causing this
issue as it's first item to scan. It is very slow solution...(3000+ files
on hdfs)

The other solution would be to write a Map Reduce Job to validate and fix
the faulty column.


Any advise is welcome.

Thanks
Francois

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message