drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [drill] cgivre commented on pull request #1888: DRILL-5956: Add Storage Plugin for Apache Druid
Date Wed, 24 Jun 2020 03:30:57 GMT

cgivre commented on pull request #1888:
URL: https://github.com/apache/drill/pull/1888#issuecomment-648561547


   @vvysotskyi 
   I'm trying to assist and rebuild the protobufs for this PR.   I have version 3.11.4 installed
and the CI is producing the following errors below.  What version should I be using?
   Thx
   
   ```
   The following changes are found in files after regenerating protobufs (output may be used
as a patchto apply):
   11
   diff --git a/contrib/native/client/src/include/drill/protobuf/Types.pb.h b/contrib/native/client/src/include/drill/protobuf/Types.pb.h
   12
   index be9fe8a..a4f30cd 100644
   13
   --- a/contrib/native/client/src/include/drill/protobuf/Types.pb.h
   14
   +++ b/contrib/native/client/src/include/drill/protobuf/Types.pb.h
   15
   @@ -13,7 +13,7 @@
   16
    #error incompatible with your Protocol Buffer headers. Please update
   17
    #error your headers.
   18
    #endif
   19
   -#if 3011004 < PROTOBUF_MIN_PROTOC_VERSION
   20
   +#if 3011001 < PROTOBUF_MIN_PROTOC_VERSION
   21
    #error This file was generated by an older version of protoc which is
   22
    #error incompatible with your Protocol Buffer headers. Please
   23
    #error regenerate this file with a newer version of protoc.
   24
   diff --git a/contrib/native/client/src/protobuf/BitControl.pb.h b/contrib/native/client/src/protobuf/BitControl.pb.h
   25
   index 3235cf4..dce43cb 100644
   26
   --- a/contrib/native/client/src/protobuf/BitControl.pb.h
   27
   +++ b/contrib/native/client/src/protobuf/BitControl.pb.h
   28
   @@ -13,7 +13,7 @@
   29
    #error incompatible with your Protocol Buffer headers. Please update
   30
    #error your headers.
   31
    #endif
   32
   -#if 3011004 < PROTOBUF_MIN_PROTOC_VERSION
   33
   +#if 3011001 < PROTOBUF_MIN_PROTOC_VERSION
   34
    #error This file was generated by an older version of protoc which is
   35
    #error incompatible with your Protocol Buffer headers. Please
   36
    #error regenerate this file with a newer version of protoc.
   ```


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



Mime
View raw message