drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kamesh <kamesh.had...@gmail.com>
Subject Re: mongodb authentication problem
Date Wed, 08 Apr 2015 14:01:12 GMT
Hi Wang,
 Still the patch for DRILL-1502 is not committed. It is still in review
state.

On Wed, Apr 8, 2015 at 2:03 PM, Wang Darrell <darrellwang74@gmail.com>
wrote:

> Hello
>
> I still can't figure it out this problem.
> After trying to solve this for almost a week.
>
> I used java to check the mongodb connection uri to see the error message.
> it came out that the error message that Drill gave me
>
> CommandFailureException: { "serverUsed" : "192.168.170.136:27017" , "ok" :
> 0.0 , "errmsg" : "not authorized on admin to execute command {
> listDatabases: 1 }"
>
> is same as the connection url like "mongodb:host:port"
>
> so the problem is
> As I set my drill storage config like this
>
> {
>   "type": "mongo",
>   "connection": "mongodb://zipsread:zipsread@localhost:27017/zips",
>   "enabled": true
> }
>
> but the drill sending the uri like "mongodb://localhost:27017"
>
> drill version is 0.8 ( but has tested on 0.7 and 0.9 and have same problem
> )
> mongodb version is 2.6.9  ( has tested on 3.0 and 2.4 and have same problem
> )
> drill is start as distributed mode ( need to use squirrel )
> mongodb is started alone , no clustering
>
> can someone help me out ?
> really stuck at it for very long time.
>



-- 
Kamesh.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message