drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Rudis <...@rud.is>
Subject Re: Compatibility Matrix for the ODBC/JDBC clients
Date Wed, 13 Feb 2019 12:53:33 GMT
Hey Joel…

My experience has been the JDBC-side was more tolerant than the free ODBC driver. It took
a bit for the ODBC driver to be released after Drill 1.13.0 and the macOS and Linux ODBC versions
(I don't use legacy Windows operating systems) kept tossing messages in logs to the point
where I rly didn't want to trust them so just used JDBC until parity was reached (IIRC it
was protocol-buffer related which makes sense since those binary bits have to be meticulously
maintained).

I've definitely mixed-and-matched JDBC & Drill version (unintentionally) without detriment,
but would (again IMO) strongly suggest keeping versions aligned.

-boB

> On Feb 13, 2019, at 4:43 AM, Joel Pfaff <joel.pfaff@gmail.com> wrote:
> 
> Hello,
> 
> Does Drill mandate the perfect alignment of the Drillbits versions and the
> ODBC/JDBC client versions, or is it possible to use an older client with a
> new server or vice versa?
> 
> Regards, Joel


Mime
View raw message