drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Vantol <robert.van...@eqworks.com>
Subject Json Complex array issue only on HDF, local storage is fine
Date Tue, 12 Mar 2019 19:00:29 GMT
This is our Json, as you see the imp node is an array of other json:



{



    "id":"21D66BC4F2BA7E24",

    "imp":[

        {

            "id":"1",

            "banner":{

                "w":160,

                "h":600,

                "pos":1,

                "topframe":1

            },

            "sessiondepth":22

        }

    ],

    "site":{

        "id":"288491",

        "cat":[

            "IAB5"

        ],

        "page":"
http://www.history101.com/discovered-photo-album-reveals-the-real-reason-why-the-titanic-sank/19/
",

        "ref":"
http://www.history101.com/discovered-photo-album-reveals-the-real-reason-why-the-titanic-sank/18/
",

        "publisher":{

            "id":"184621"

        },

        "content":{

            "keywords":"2"

        }

    }



When we drill locally on a windows machine with the json sitting on the
file system using:



Select t.id, t.imp[0].banner.w, t.imp[0].banner.h  from rv.`bid.json` t;



It returns the information correctly.

When we take that same json and place it on our HDF the imp node is
returned as null we are able to pull out other nodes, and even the other
Simple array (site.cat[0]), just not the imp node. We have tried to flatten
it and have tried: ALTER SESSION SET `store.json.all_text_mode` = true;



But nothing is working. We are using newly downloaded Drill 1.15



Is there any help you can give me? I am at a loss…



Rob









[image: sm_eq_works_logo]

*  Robert VanTol*
 Digital Consultant & Information Architect


*RobV@eqworks.com <RobV@eqworks.com>* | *T * 416 260 4759

1235 Bay Street, Suite 401, Toronto ON, M5R 2A9

EQ Digital  | www.EQworks.com <http://www.eqworks.com/>

Follow us:  [image: cid:image007.png@01CE983F.AC5709F0]
<https://twitter.com/eqworkscorp> [image:
cid:image006.png@01CE983F.AC5709F0]
<https://www.facebook.com/eqworkscorp>  [image:
cid:image005.png@01CE983F.AC5709F0]
<https://www.linkedin.com/company/3202191?trk=tyah>

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message