dubbo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ralf0131 (GitHub) <git...@apache.org>
Subject [GitHub] [incubator-dubbo] ralf0131 commented on issue #3775: [Dubbo-3764]Merge dubbo rpc xmlrpc
Date Sat, 06 Apr 2019 02:19:05 GMT
> List of dependencies and the LICENSE:
> 
> * javax.servlet: CDDL + GPLv2 with classpath exception (https://apache.org/legal/resolved.html#category-x
says we can't include GPLv2 but "special exceptions to the GNU GPL (e.g. GNU Classpath) unless
otherwise permitted elsewhere on this page." so I think there's no problem)
> * javax.portlet: Apache 2.0
> * junit: EPL 1.0
> * org.eclipse.jetty: Apache 2.0 + EPL 1.0
> * org.mortbay.jetty: Apache 2.0 + EPL 1.0

Yes, I think the license are fine. If a dependency is dual/multi-license, we can choose the
most permissive one. 

[ Full content available at: https://github.com/apache/incubator-dubbo/pull/3775 ]
This message was relayed via gitbox.apache.org for notifications@dubbo.apache.org


Mime
View raw message