eagle-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Huizhi Lu <ihuizhi...@gmail.com>
Subject Re: EAGLE-517
Date Fri, 02 Sep 2016 09:11:19 GMT
Hi Jayesh,

The Web UI has been re-designed. Unfortunately, it is still under
development. So the new web ui is not ready for now. I believe it should be
ready soon.

Currently we can use REST API to process post/get
policies/publisher/topologies, etc.. I am using POSTMAN.

If you need the json templates for the post/get api, let us know.

-Huizhi

On Fri, Sep 2, 2016 at 12:49 AM, Jayesh Senjaliya <jhsonline@gmail.com>
wrote:

> Hi Huizhi,
>
> Yes, I am running eagle-server now instead of eagle-webservice.
>
> but still not sure on how can i start the web UI.
>
> Thanks for explaining.
> Jayesh
>
>
> On Fri, Sep 2, 2016 at 12:30 AM, Huizhi Lu <ihuizhi.lu@gmail.com> wrote:
>
> > Jayesh,
> >
> > The development guide in Intellij is not updated since current develop
> > branch has replaced eagle-webservice with eagle-server as Edward
> mentioned
> > in the previous email. So eagle-webservice is not necessary in develop
> > branch any more.
> >
> > Eagle-webservice is kept Branch 0.3.x and 0.4.x which have been released.
> >
> > So I would build eagle-server and run it instead of eagle-webservice.
> > Run eagle-server with this class in your intellij.
> > incubator-eagle/eagle-server/src/main/java/org/apache/
> > eagle/server/ServerMain.java
> >
> >
> > -pkuwm
> >
> >
> >
> > On Thu, Sep 1, 2016 at 11:43 PM, Jayesh Senjaliya <jhsonline@gmail.com>
> > wrote:
> >
> > > Thanks Edward.
> > >
> > > I was following online docs to setup the project. (
> > > http://eagle.apache.org/docs/development-in-intellij.html )
> > > I was trying to build eagle-webservice that is where i hit all those
> > > issues.
> > >
> > > [ERROR] Failed to execute goal
> > > org.apache.maven.plugins:maven-compiler-plugin:3.5.1:compile
> > > (default-compile) on project eagle-webservice: Compilation failure:
> > > Compilation failure:
> > > [ERROR]
> > > /src/apache/eagle-develop/eagle-webservice/src/main/
> > > java/org/apache/eagle/service/security/profile/
> > > ApplicationSchedulerListener.java:[22,17]
> > > error: package akka.actor does not exist
> > >
> > >
> > > I can run eagle-server now.
> > >
> > > is the UI still under eagle-webservice ?
> > >
> > > - Jayesh
> > >
> > >
> > > On Thu, Sep 1, 2016 at 9:55 PM, Edward Zhang <yonzhang2012@apache.org>
> > > wrote:
> > >
> > > > Hi Jayesh,
> > > >
> > > > eagle-webservice is going to be replaced by eagle-server, I could not
> > > find
> > > > build issue in your ticket. Please copy/paste your build error.
> > > >
> > > > Thanks
> > > > Edward
> > > >
> > > > On Thu, Sep 1, 2016 at 2:20 PM, Jayesh Senjaliya <
> jhsonline@gmail.com>
> > > > wrote:
> > > >
> > > > > Hi Guys,
> > > > >
> > > > > I found some issues while building it.
> > > > > can somebody pls take a look at the ticket : EAGLE-517 ?
> > > > >
> > > > > Thanks
> > > > > Jayesh
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message