etch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Holger Grandy <Holger.Gra...@bmw-carit.de>
Subject RE: trying to build c example helloworld...
Date Mon, 11 Oct 2010 11:13:34 GMT
Hi Scott, 

I checked this again at my box. Installing the patch for VS 2005 SP1 from 
http://support.microsoft.com/kb/949009/ solved the issue for me. We should add 
this to the build information on the website.

Cheers, 
Holger

-----Original Message-----
From: Holger Grandy [mailto:grandyho@apache.org] 
Sent: Sonntag, 10. Oktober 2010 20:32
To: etch-dev@incubator.apache.org
Subject: Re: trying to build c example helloworld...

Hi Scott,

interesting. it seems the debug info flies (*.pdb) are not working correctly
on your machine. My first quick guess would be
http://support.microsoft.com/kb/949009/

The module you used was buillt on the apache win32 build server, which is
running Microsoft Visual Studio Version 9.0.30729.1, which is 2008. This would
fit to the KB article above. Could you try the fix?

If it does not work and if you just want to try out, remove the *.pdb
files (you will
get warnings then of course when linking) or build "release".

Cheers,
Holger


On Sun, Oct 10, 2010 at 5:50 PM, scott comer <wert1y@mac.com> wrote:
>  ok, so i've downloaded the release distribution and installed it.
>
> i'm using ms visual studio 2005
>
> i've run cmake to get vs project and solution files.
>
> NOTE: when running under windows 7, you have to start a cmd tool in
> administrator mode to do that.
>
> i've set the environment variables ETCH_HOME and APR_ICONV_PATH.
>
> i've opened visual studio (again, as administrator).
>
> opened the solution etch-c-helloworld.
>
> solution configuration: debug
> solution playform: win32
>
> picked build/build solution.
>
> build fails, here's the log:
>
> 1>------ Build started: Project: etch-c-helloworld-client, Configuration:
> Debug Win32 ------
> 2>------ Build started: Project: etch-c-helloworld-server, Configuration:
> Debug Win32 ------
> 2>Compiling...
> 1>Compiling...
> 2>helloworld_remote.c
> 1>helloworld_remote.c
> 2>helloworld_valufact.c
> 1>helloworld_valufact.c
> 1>helloworld_server.c
> 2>helloworld_server.c
> 1>helloworld_remote_server.c
> 2>helloworld_remote_server.c
> 2>helloworld_remote_client.c
> 1>helloworld_remote_client.c
> 1>helloworld_client_stub.c
> 2>helloworld_client_stub.c
> 1>helloworld_helper.c
> 2>helloworld_helper.c
> 2>helloworld_server_stub.c
> 1>helloworld_server_stub.c
> 1>helloworld_client.c
> 2>helloworld_client.c
> 2>helloworld_interface.c
> 1>helloworld_interface.c
> 2>helloworld_listener_main.c
> 1>helloworld_client_main.c
> 2>helloworld_server_impl.c
> 1>helloworld_client_implx.c
> 2>helloworld_server_implx.c
> 1>helloworld_client_impl.c
> 2>Generating Code...
> 1>Generating Code...
> 1>Compiling manifest to resources...
> 2>Compiling manifest to resources...
> 1>Linking...
> 2>Linking...
> 1>etch.lib(etch_arraylist.obj) : fatal error LNK1103: debugging information
> corrupt; recompile module
> 2>etch.lib(etch_arraylist.obj) : fatal error LNK1103: debugging information
> corrupt; recompile module
> 1>Build log was saved at "file://c:\Program Files (x86)\Apache Software
> Foundation\apache-etch-1.1.0\examples\helloworld\target\etch-c-helloworld-client.dir\Debug\BuildLog.htm"
> 1>etch-c-helloworld-client - 1 error(s), 0 warning(s)
> 2>Build log was saved at "file://c:\Program Files (x86)\Apache Software
> Foundation\apache-etch-1.1.0\examples\helloworld\target\etch-c-helloworld-server.dir\Debug\BuildLog.htm"
> 2>etch-c-helloworld-server - 1 error(s), 0 warning(s)
> 3>------ Skipped Build: Project: ALL_BUILD, Configuration: Debug Win32
> ------
> 3>Project not selected to build for this solution configuration
> ========== Build: 0 succeeded, 2 failed, 1 up-to-date, 1 skipped ==========
>
>

Mime
View raw message